Closed Bug 904810 Opened 6 years ago Closed 6 years ago

Unexpected up/down arrow result

Categories

(Core :: Editor, defect)

23 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla26
Tracking Status
firefox22 --- unaffected
firefox23 --- affected
firefox24 + verified
firefox25 + fixed
firefox26 + fixed

People

(Reporter: gordon.fogus, Assigned: mats)

References

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130617145905

Steps to reproduce:

0) I upgraded from 22 to 23
1) I selected text using shift and the arrow keys.
2) I copied the text using Ctrl+C.
3) I pressed the down arrow to move to the next line.


Actual results:

The cursor went to the end of the current line.


Expected results:

The cursor should have gone to the next line.  That's what it did in all previous versions of Firefox and it's what it does in every other text editing program I've used.

Example (cursor represented with a "|" symbol, selected text is that text between the "*" symbols)
State 1:
*asdf asdf asdf*|
sdfg sdfg sdfg

Action: press down key on keyboard

State 2 (what happens in >23):
asdf asdf asdf|
sdfg sdfg sdfg

State 2 (what happens in <22):
asdf asdf asdf
sdfg sdfg sdfg|
The new broken caret behavior was introduced by Bug 859088.
At least on wndows7, the behavior did not mach another windows application such as notepad.exe as well as Internet explorer9.

9a09523eb5dd	Mats Palmgren — Bug 859088 - Left/Right Arrow key after selection should move to the beginning/end of selection respectively (on all platforms). r=ehsan
Blocks: 859088
Status: UNCONFIRMED → NEW
Component: Untriaged → Editor
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
Mats, tracking and passing this on to you since this may be a fallout from Bug 859088, feel free to reassign if needed :)
Assignee: nobody → matspal
Attached patch fix+testSplinter Review
Attachment #791294 - Flags: review?(ehsan)
Attachment #791294 - Flags: review?(ehsan) → review+
https://hg.mozilla.org/mozilla-central/rev/abed25d32cdd
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
Hey Mats, is this ready for uplift ?
Flags: needinfo?(matspal)
Comment on attachment 791294 [details] [diff] [review]
fix+test

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 859088
User impact if declined: with some text selected, the caret ends up in the wrong position after UP/DOWN (bug occurs on Windows only)
Testing completed (on m-c, etc.):  on m-c since 2013-08-17
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #791294 - Flags: approval-mozilla-beta?
Attachment #791294 - Flags: approval-mozilla-aurora?
Flags: needinfo?(matspal)
Attachment #791294 - Flags: approval-mozilla-beta?
Attachment #791294 - Flags: approval-mozilla-beta+
Attachment #791294 - Flags: approval-mozilla-aurora?
Attachment #791294 - Flags: approval-mozilla-aurora+
Verified as fixed on:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0 (20130822154523)
QA Contact: ioana.budnar
You need to log in before you can comment on or make changes to this bug.