Closed Bug 905120 Opened 7 years ago Closed 4 years ago

lufthansa.de sends desktop site to B2G

Categories

(Web Compatibility :: Mobile, defect, P3)

Other
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: hsteen, Assigned: karlcow, Mentored)

References

()

Details

(Whiteboard: [serversniff] [country-de][contactready])

Attachments

(1 file)

1) http://lufthansa.de should (probably) send FirefoxOS browsers to mobile.lufthansa.com

2) There is server-side browser sniffing on mobile.lufthansa.com that omits certain features (like autocomplete for departure/destination fields) when FirefoxOS is used (presumably classifying it as an "unknown" and less capable mobile browser in the backend logic). For example these scripts are removed, compared to what Firefox Android UA gets:

<script type="text/javascript" src="/js/searchfield.js;jsessionid=DB345BC5D669BF02AF1214C442E4E2D4.portal14b?l=en">
</script> 
<script type="text/javascript" src="/js/airportlist.do;jsessionid=DB345BC5D669BF02AF1214C442E4E2D4.portal14b?full=1&amp;cities=1&amp;l=en">
</script>
Priority: -- → P3
Whiteboard: [serversniff] [country-de]
URL:
Summary: lufthansa.de sends desktop site to B2G → lufthansa.de sends desktop site to B2G ▪ [>>]
Whiteboard: [serversniff] [country-de] → [serversniff] [country-de]
Summary: lufthansa.de sends desktop site to B2G ▪ [>>] → lufthansa.de sends desktop site to B2G
Whiteboard: [serversniff] [country-de] → [serversniff] [country-de][contactready]
This seems to be resolved. 

Tested on Firefox Android and Firefox OS, Opera mobile, Opera mini, they all receive the mobile Web site.
Assignee: nobody → kdubost
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
I get desktop site in FxOS
Status: REOPENED → NEW
Yes regression. I guess they changed their framework.
to contact again.


→ echo "";echo ""; URI='http://www.lufthansa.com/online/portal/lh/us/homepage' 
; echo "# iOS SAFARI"; http --print hH GET $URI "User-Agent: $APHUA"  ;echo "# 
FIREFOX OS"; http --print hH GET $URI "User-Agent: $FOSUA" 


# iOS SAFARI
GET /online/portal/lh/us/homepage HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: www.lufthansa.com
User-Agent:  Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3

HTTP/1.1 302 Moved Temporarily
Cache-Control: max-age=600
Connection: keep-alive
Content-Language: en-US
Content-Length: 0
Content-Type: text/plain
Date: Fri, 07 Feb 2014 17:29:54 GMT
Location: http://mobile.lufthansa.com
Redirect-Cause: CookieDetector: Mobile User
Server: IBM_HTTP_Server

# FIREFOX OS
GET /online/portal/lh/us/homepage HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: www.lufthansa.com
User-Agent:  Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

HTTP/1.1 200 OK
Cache-Control: private, max-age=600
Connection: keep-alive
Content-Encoding: gzip
Content-Language: en
Content-Length: 20904
Content-Location: /online/portal/lh/us/homepage2011/!ut/p/c5/04_SB8K8xLLM9MSSzPy8xBz9CP0os3hnf0PLMI9QZzNzb29DA0d_J093F2dnM28vA30v_aj0nPwkoMpwkF7cao0NIPIGOICjgb6fR35uqn5BdnCQhaOiIgCRcug0/dl3/d3/L2dBISEvZ0FBIS9nQSEh/
Content-Type: text/html; charset=UTF-8
Date: Fri, 07 Feb 2014 17:29:54 GMT
IBM-Web2-Location: /online/portal/lh/us/homepage2011/!ut/p/c5/04_SB8K8xLLM9MSSzPy8xBz9CP0os3hnf0PLMI9QZzNzb29DA0d_J093F2dnM28vA30v_aj0nPwkoMpwkF7cao0NIPIGOICjgb6fR35uqn5BdnCQhaOiIgCRcug0/dl3/d3/L2dBISEvZ0FBIS9nQSEh/
Server: IBM_HTTP_Server
Vary: Accept-Encoding
Whiteboard: [serversniff] [country-de][contactready] → [serversniff] [country-de][contactready][mentor=astevenson]
The behaviour is pretty odd now.. First you do indeed get the desktop site, but if you try to click some menu or link you're all of a sudden taken to mobile.lufthansa.com instead. Pretty confusing!

Auto-complete is still missing from the "Book" section, but oddly enough it's present elsewhere like in the "Flight status" search screens, and works fine.
Confirmed on both remarks from Hallvord for Firefox OS.

# iOS Safari (iPod)
a redirection and then a fail to access any site. I suspect an infinite loop.

# Firefox Android
Redirection to mobile site.
Same issue with Book/Flight Status 

# UC Web, Opera, Chrome
Redirection to mobile
No issue with Book/Flight

We should open a separate bug for the autocompletion.


Let's see about the first page.

→ http --print hH GET http://www.lufthansa.de/ "User-Agent: Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0" 
GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: www.lufthansa.de
User-Agent:  Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

HTTP/1.1 301 
Accept-Ranges: bytes
Cache-Control: no-cache
Connection: close
Content-Length: 208
Content-Type: text/html; charset=IBM-850
Date: Fri, 30 May 2014 05:14:51 GMT
Expires: Fri, 30 May 2014 05:14:51 GMT
Last-Modified: Fri, 30 May 2014 05:14:51 GMT
Location: http://www.lufthansa.com/online/portal/lh/de/homepage
Pragma: no-cache
Server: Lufthansa Proxy


→ http --print hH GET http://www.lufthansa.com/online/portal/lh/de/homepage "User-Agent: Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0" 
GET /online/portal/lh/de/homepage HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: www.lufthansa.com
User-Agent:  Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

HTTP/1.1 200 OK
Cache-Control: private, max-age=600
Connection: keep-alive
Content-Encoding: gzip
Content-Language: en
Content-Length: 20308
Content-Location: /online/portal/lh/de/homepage2011/!ut/p/c5/04_SB8K8xLLM9MSSzPy8xBz9CP0os3hnf0PLMI9QZ7MwCw9XA0dvJ9OAEEMvR0sDI6B8pFm8AQ7gaEBAt5d-VHpOfhLQnnCQzTjVeoQZQeTx2OTnkZ-bql-QG1EZHJCuCAAGCADZ/dl3/d3/L2dBISEvZ0FBIS9nQSEh/
Content-Type: text/html; charset=UTF-8
Date: Fri, 30 May 2014 05:16:06 GMT
IBM-Web2-Location: /online/portal/lh/de/homepage2011/!ut/p/c5/04_SB8K8xLLM9MSSzPy8xBz9CP0os3hnf0PLMI9QZ7MwCw9XA0dvJ9OAEEMvR0sDI6B8pFm8AQ7gaEBAt5d-VHpOfhLQnnCQzTjVeoQZQeTx2OTnkZ-bql-QG1EZHJCuCAAGCADZ/dl3/d3/L2dBISEvZ0FBIS9nQSEh/
Server: IBM_HTTP_Server
Vary: Accept-Encoding



OH! I understood the issue with the iPod Safari. I guess Safari is really trying to make sense of the encoding even for a redirection.


→ http --print hH GET http://lufthansa.de/ "User-Agent: Mozila/5.0 (iPod; U; CPU like Mac OS X; en) AppleWebKit/420.1 (KHTML, like Geckto) Version/3.0 Mobile/3A101a Safari/419.3" 

GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: lufthansa.de
User-Agent:  Mozila/5.0 (iPod; U; CPU like Mac OS X; en) AppleWebKit/420.1 (KHTML, like Geckto) Version/3.0 Mobile/3A101a Safari/419.3

HTTP/1.1 301 
Accept-Ranges: bytes
Cache-Control: no-cache
Connection: close
Content-Length: 208
Content-Type: text/html; charset=IBM-850
Date: Fri, 30 May 2014 05:31:52 GMT
Expires: Fri, 30 May 2014 05:31:52 GMT
Last-Modified: Fri, 30 May 2014 05:31:52 GMT
Location: http://www.lufthansa.com/online/portal/lh/de/homepage
Pragma: no-cache
Server: Lufthansa Proxy




So here you think all the same… than Firefox OS.
Well yes exactly. What's happening if I do 

→ http -b GET http://lufthansa.de/ "User-Agent: Mozila/5.0 (iPod; U; CPU like Mac OS X; en) AppleWebKit/420.1 (KHTML, like Geckto) Version/3.0 Mobile/3A101a Safari/419.3" 

http: error: LookupError: unknown encoding: IBM-850


→ http -b GET http://www.lufthansa.de/ "Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0"

http: error: LookupError: unknown encoding: IBM-850


woot?! Indeed. Safari old version is failing because the charset doesn't make sense.
Content-Type: text/html; charset=IBM-850
Mentor: astevenson
Whiteboard: [serversniff] [country-de][contactready][mentor=astevenson] → [serversniff] [country-de][contactready]
So tested and we receive now the Mobile Web site again.
I'm closing it And I'm also cloning for the Autocompletion.
Status: NEW → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Blocks: 1055947
If this was fixed at some point it's now regressed again :(
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → NEW
to note that Firefox Android is redirected to a mobile domain.
https://mobile.lufthansa.com/hpg/start.jsp?c=DE&l=de
but Firefox OS is getting a responsive Web site.

As such I think the issue is somehow solved.
Status: NEW → RESOLVED
Closed: 6 years ago4 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.