Closed Bug 905170 Opened 7 years ago Closed 6 years ago

Test failure "The theme 'plain.theme@quality.mozilla.org' is enabled - got 'false'" in testAddons_changeTheme/test2.js

Categories

(Mozilla QA Graveyard :: Mozmill Tests, defect, P1)

defect

Tracking

(firefox25 unaffected, firefox26 fixed)

RESOLVED FIXED
Tracking Status
firefox25 --- unaffected
firefox26 --- fixed

People

(Reporter: cosmin-malutan, Assigned: andrei)

References

()

Details

(Keywords: regression, Whiteboard: [mozmill-test-failure][fixed by bug 911621])

Attachments

(1 file, 1 obsolete file)

Happened today on Windows Vista (x86) with Nightly it:
http://mozmill-daily.blargon7.com/#/functional/report/b7ef1fb3d9703aeaf2c46e07d2bd253b

I could't reproduce it locally, probably it's an machine issue.
This is suspicious and I would like to see some investigation today. When I see the list of add-ons in the report the default theme is marked as enabled and compatible. Could this be a misbehavior of the Add-ons manager API?

Failed on Vista (mm-win-vista-3) again:
http://mozmill-daily.blargon7.com/#/functional/report/b7ef1fb3d9703aeaf2c46e07d2cb817b

> Tema predefinito 26.0a1 (enabled, compatible)
Assignee: nobody → andrei.eftimie
Status: NEW → ASSIGNED
This failed again today on fr locale, Windows Vista.
I believe bug 904610 is dependent on this one as it failed once on the following test (test3) and since then we only caught this error in test2.
Which Vista machine? I believe it's always the same node which causes us the problems here.
mm-win-vista-3 indeed, it's the same node as you stated in comment 1.
Does not seem to be related to 1 machine.
Failed on mm-win-vista-32-2 (I do remeber we recently renamed them, is this the same machine mentioned previously?) and on mm-win-7-32-3
Priority: -- → P1
This fails intermittently, so not a P1 but P2.
Priority: P1 → P2
This fails 2-3 times a day on CI, yet I haven't been able to reproduce the failure locally in 100 runs (slimmed down testruns)
No longer blocks: 904610
I wasn't able to reproduce this on CI either.
(Same machine, same FF build)

This is puzzling since it fails a couple of times per day on the regular testruns.
Attached patch skip.patch (obsolete) — Splinter Review
Yes, this reproduces constantly now with the latest nightly.

Here is a skip patch.
I'll do a regression range now.
Attachment #803005 - Flags: review?(andreea.matei)
Comment on attachment 803005 [details] [diff] [review]
skip.patch

Review of attachment 803005 [details] [diff] [review]:
-----------------------------------------------------------------

The nit applies to all test files.

::: tests/functional/restartTests/testAddons_changeTheme/test1.js
@@ +101,5 @@
> +
> +setupModule.__force_skip__ = "Bug 905170 - The theme 'plain.theme@quality.mozilla.org'" +
> +                             "is enabled - got 'false'";
> +teardownModule.__force_skip__ = "Bug 905170 - The theme 'plain.theme@quality.mozilla.org'" +
> +                                "is enabled - got 'false'";

Small update needed here cause the message will get linked together without a whitespace between the concatenated strings.
Attachment #803005 - Flags: review?(andreea.matei) → review-
Attached patch skip.patchSplinter Review
Added a space to have a nice message.
Attachment #803005 - Attachment is obsolete: true
Attachment #803015 - Flags: review?(andreea.matei)
Comment on attachment 803015 [details] [diff] [review]
skip.patch

Review of attachment 803015 [details] [diff] [review]:
-----------------------------------------------------------------

Disabled:
http://hg.mozilla.org/qa/mozmill-tests/rev/60eccf81d91b (default)
Attachment #803015 - Flags: review?(andreea.matei) → review+
Whiteboard: [mozmill-test-failure][mozmill-test-skipped]
What is the problem here, Andrei? We have to get this fixed asap.
Clear regression.

Passes with Nightly from 2013-09-10
Fails with Nightly from 2013-09-11

Working with tinderbox builds to get the regressor changeset.
Not sure why this has been set to critical, we don't have a crash, abort, or freeze here.
Severity: critical → normal
(In reply to Andrei Eftimie from comment #15)
> Passes with Nightly from 2013-09-10
> Fails with Nightly from 2013-09-11

Sounds like a different issue given that this bug is already open a couple of weeks. But lets see.
(In reply to Henrik Skupin (:whimboo) from comment #17)
> (In reply to Andrei Eftimie from comment #15)
> > Passes with Nightly from 2013-09-10
> > Fails with Nightly from 2013-09-11
> 
> Sounds like a different issue given that this bug is already open a couple
> of weeks. But lets see.

Indeed, lets see what changed for this to fail constantly.
It _might_ be a completely different issue.
Regressor is bug 888347
Changeset: http://hg.mozilla.org/integration/mozilla-inbound/rev/efc4235dd32d

Does this happen because we're in a restart test?
Blocks: 888347
First thought was that startUserShutdown() might need an update, but we also fail in mozmill 2.0 with restartApplication()
The new failure has the same cause as bug 915193

I propose to move all discussions there, since the original failure in this bug is probably unrelated.
As what is mentioned on bug 911820 it explains why it was failing sporadically before. Lets hope for a quick fix.
Depends on: 911820
Keywords: regression
Hardware: x86 → All
Whiteboard: [mozmill-test-failure][mozmill-test-skipped] → [mozmill-test-failure][mozmill-test-skipped][blocked by bug 915193]
Whiteboard: [mozmill-test-failure][mozmill-test-skipped][blocked by bug 915193] → [mozmill-test-failure][mozmill-test-skipped][blocked by bug 911820]
No longer depends on: 911820
Fixed by bug 911621 and reenabled in bug 915193.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [mozmill-test-failure][mozmill-test-skipped][blocked by bug 911820] → [mozmill-test-failure][blocked by bug 911820]
Whiteboard: [mozmill-test-failure][blocked by bug 911820] → [mozmill-test-failure][fixed by bug 911621]
Product: Mozilla QA → Mozilla QA Graveyard
You need to log in before you can comment on or make changes to this bug.