[Messages] Phone number contact in SMS message doesn't redirect user to appropriate screen

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::SMS
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Montoya Clemmons (MClemmons), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 790368 [details]
Repro SMS Issue

Description:
Receiving and selecting the phone number within an SMS message from an unknown contact redirects user to the Dialer's call interface rather than providing options to call or either create or add to existing contact

Repro Steps:
1) Updated Unagi to Build ID: 20130814040203
2) Select SMS App
3) Select Message from unknown contact
4) Select Phone number in orange header from unknown contact

Actual:
Dialer App launches with phone number of unknown contact pre-populated

Expected:
Phone number from unknown contact appears at top center of screen, four buttons appear: 
Call, Create new contact, Add to an existing contact, Cancel

Environmental Variables
Build ID: 20130814040203
Gecko: http://hg.mozilla.org/mozilla-central/rev/3c61cc01a3b1
Gaia: 9e0f6e30e5e28f88b4bbb4acb5e1fc99cdf7b7e7
Platform Version: 26.0a1

Notes:
Repro frequency: 5 out of 20 times. Did not occur first thing this morning after flashing device, approximately 9:10 am PT. Has reproduced intermittently since that time
Test Suite Name: SMS
Link to failed test case: https://moztrap.mozilla.org/manage/cases/?filter-id=7941
See attached: logcat while actual results appeared on Unagi 1.2 
Actual results not reproducible on Leo 1.1 commercial or Moz build for 08142013. Expected results occur on Leo 1.1 for each build

Depends on 888150
I only observe the correct behaviour on gaia@master (4adf16422ddde49de5280270902ec059d20de540); please confirm, thanks!
Flags: needinfo?(mclemmons)
Summary: [B2G][SMS]Phone number contact in SMS message doesn't redirect user to appropriate screen → [Messages] Phone number contact in SMS message doesn't redirect user to appropriate screen
(Reporter)

Comment 2

5 years ago
Currently, we are not able to build Custom Builds. Therefore, we were unable to reproduce on the build provided in Comment 1.

Below are Environmental Variables from today to reproduce the previously documented behavior in Comment 0. 

Expected results of the dark background screen with options Call, Create new contact, and Add to an existing contact displayed during all six attempts to reproduce. 

Build ID: 20130816040203
Gecko: http://hg.mozilla.org/mozilla-central/rev/6f265af4e3d8
Gaia: be95c3b6757290fff4fdde7a2b73c68f599131a1
Flags: needinfo?(mclemmons)
Thanks!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.