Send device model with UA update query

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Browser
RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: jchen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Once bug 897221 is fixed, we need to send partner/device information as part of the update query.
Lawrence, what kind of information should be sent? I'm thinking of partner and device model? And how do we access that information in Gecko?
Flags: needinfo?(lmandel)
Hmm, while I can see the use I'm not sure that this is possible. I'm not aware of any JS APIs that expose partner or device. (This should be by design.) There may be an API that exposes the network information but I don't know that we can rely on that as a device may roam. We can key off of the UA but that will only inform about the device and not the partner. However, the UA may be the best that we can do.
Flags: needinfo?(lmandel)
What is the "UA update query" and why do you think this is to do with the browser app? Please provide more information.
Flags: needinfo?(nchen)
(In reply to Ben Francis [:benfrancis] from comment #3)
> What is the "UA update query" and why do you think this is to do with the
> browser app? Please provide more information.

This is a follow-up to bug 897221, which is about having a mechanism to dynamically update the list of UA overrides by sending a query to a Mozilla server. This feature is targeted at Fennec and the B2G browser.

However, based on Lawrence's comment, I'll mark this as WONTFIX for now.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(nchen)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.