Closed Bug 905447 Opened 6 years ago Closed 6 years ago

[B2G][Unagi][1.2][Everything.me] There is no Favorite Button available in Everything.me.

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jzimbrick, Assigned: crdlc)

References

Details

(Keywords: regression, smoketest)

Attachments

(2 files)

Description:
There is no favorite button available when browsing Everything.me.

Repro Steps:
1. Update Buri device to moz 1.2 build 20130814040203.
2. From the homescreen, scroll to the Everything.Me searchbar.
3. Tap a site from Everything.me (Facebook, Twitter, Tumblr, etc.)
4. With an Everything.me page selected, tap the bottom of the screen near the orange arrow to bring up the nav bar.
5. Observe that the Favorite button is missing in the space between the refresh button and the hide button. (See screenshot.)

Actual:
The Everything.me Favorite icon is missing in the nav bar.

Expected:
The Everything.me Favorite icon appears in the nav bar.

Environmental Variables
Build ID: 20130814040203
Gecko: http://hg.mozilla.org/mozilla-central/rev/3c61cc01a3b1
Gaia: 9e0f6e30e5e28f88b4bbb4acb5e1fc99cdf7b7e7
Platform Version: 26.0a1

Notes:
Repro frequency: 100%
See attached: Screenshot.
Ran - Can you take a look?
No longer depends on: b2g-central-dogfood
Flags: needinfo?(ran)
Keywords: regression
blocking-b2g: --- → koi?
Cristian, it seems dataset.originURL is undefined when getting here https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/wrapper.js#L134.

Looking into EvmeManager, it looks like "params" is providing the correct data.
https://github.com/mozilla-b2g/gaia/blob/master/apps/homescreen/everything.me/js/etmmanager.js#L8

Can you look into this?
Flags: needinfo?(ran) → needinfo?(crdlc)
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
Flags: needinfo?(crdlc)
Hi,

   There is a regression from bug 819882. The last parameter here [1] is truncated to a specific length (icon is defined as data:image) when it is received on window_manager and all features are not parsed. Could you take a look to this problem Olav?

Thanks a lot

[1] https://github.com/mozilla-b2g/gaia/blob/master/apps/homescreen/everything.me/js/etmmanager.js#L148
Assignee: crdlc → nobody
Status: ASSIGNED → NEW
Flags: needinfo?(olav)
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
Blocks: 819882
Attached file Patch v1
Attachment #792270 - Flags: review?(alive)
Component: Gaia::Everything.me → Gaia::System
I see you found and fixed my error with github.com/mozilla-b2g/gaia/pull/11614 . Thanks!
Flags: needinfo?(olav)
No problem, it is not an error, a mistake very common what I did some months ago jeje and for this reason I detect the problem soon. Thanks to you
Comment on attachment 792270 [details]
Patch v1

r+ but FYI I had fixed this in bug 905112.
Attachment #792270 - Flags: review?(alive) → review+
(In reply to Alive Kuo [:alive] from comment #7)
> Comment on attachment 792270 [details]
> Patch v1
> 
> r+ but FYI I had fixed this in bug 905112.

Should we then close this out as fixed by bug 905112 and not merge this pull request then?
(In reply to Jason Smith [:jsmith] from comment #8)
> (In reply to Alive Kuo [:alive] from comment #7)
> > Comment on attachment 792270 [details]
> > Patch v1
> > 
> > r+ but FYI I had fixed this in bug 905112.
> 
> Should we then close this out as fixed by bug 905112 and not merge this pull
> request then?

I think so.
Okay. Marking fixed by bug 905112 then.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Nice, thanks Alive
blocking-b2g: koi? → ---
You need to log in before you can comment on or make changes to this bug.