Closed Bug 905567 Opened 8 years ago Closed 8 years ago

Expose navigator.MozInputMethod to desktop build

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 906096

People

(Reporter: xyuan, Assigned: janjongboom)

References

Details

We need to move the implementation of the new keyboard API from b2g/ to dom/, so that we can access navigator.MozInputMethod from Firefox desktop build.

navigator.MozInputMethod we can launch gaia keyboard directly from Firefox desktop and it will provide much convenience for developing and debugging keyboard app.

Aslo it is helpful for us to standardize the virtual keyboard API and widen its use if necessary.

We won't ship the API on desktop right now and will make it pref enabled.
I tried this once with current B2G's implementation of MozInputMethod. The biggest problem is that it heavily depends on B2G's forms.js which is not available in Firefox desktop build.
At the moment we sideload forms.js in desktop-helper in gaia builds with DEBUG=1. We can still do that.
(In reply to Kan-Ru Chen [:kanru] from comment #1)
> I tried this once with current B2G's implementation of MozInputMethod. The
> biggest problem is that it heavily depends on B2G's forms.js which is not
> available in Firefox desktop build.
Yes, it is one of the problems needs to solve. Is is required to load forms.js on desktop build. desktop-help add-on will give some hint.
See tools/extensions/browser-helper@gaiamobile.org/bootstrap.js lines 180 and further. Event forwarding and loading of forms.js.

Also see https://github.com/comoyo/gaia/commit/6de285e6d47bc4327e9b3a5225c5a7e22dbab33f for all new events.
Assignee: nobody → kchen
Blocks: 906096
Stealing this, didn't realize it was a separate bug. If you're working on it please drop me a line.
Assignee: kchen → janjongboom
Addressed in bug 906096 so closing this one.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 906096
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 906096
You need to log in before you can comment on or make changes to this bug.