Closed Bug 905902 Opened 9 years ago Closed 4 years ago

Crash while scrolling complex and big web pages

Categories

(Core :: Graphics, defect)

26 Branch
x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox34 --- wontfix
firefox35 --- wontfix
firefox36 --- wontfix
firefox37 --- wontfix
firefox39 --- affected
firefox40 --- affected
firefox41 --- affected
firefox42 --- affected
firefox47 --- affected
firefox-esr38 --- affected
firefox-esr45 --- affected

People

(Reporter: wanliyou, Unassigned, NeedInfo)

Details

(Keywords: crash)

Crash Data

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20130815030203

Steps to reproduce:

1. Open large PDF files
2. Scroll around fast


Actual results:

Crash


Expected results:

Smooth Scrolling
ID: b450369b-3516-42a7-92b5-841932130816
Signature: igd10umd32.dll@0x1fcfb9
Crash Signature: igd10umd32.dll@0x1fcfb9
Provide PDF url or testcase, please.

https://crash-stats.mozilla.com/report/index/b450369b-3516-42a7-92b5-841932130816
Severity: normal → critical
Crash Signature: igd10umd32.dll@0x1fcfb9 → [@ igd10umd32.dll@0x1fcfb9 ]
Flags: needinfo?(wanliyou)
Keywords: crash
Version: Trunk → 26 Branch
http://www.iab.net/media/file/VASTv3.0.pdf
Or some Google documents which have many pages.
Flags: needinfo?(wanliyou)
It doesn't crash for me.

1) Could you paste here the graphics section of about:support. In addition, be sure your GPU drivers are up-to-date.

2) Could you try with HWA disabled.
https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration
Flags: needinfo?(wanliyou)
Lenovo X220

Application Basics
------------------

Name: Firefox
Version: 26.0a1
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:26.0) Gecko/20100101 Firefox/26.0

Extensions
----------

Name: Adblock Plus
Version: 2.3.2
Enabled: true
ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Name: feedly
Version: 16.0.528
Enabled: true
ID: feedly@devhd

Name: Movie Critiques
Version: 0.1
Enabled: true
ID: Critiques@girishsharma

Important Modified Preferences
------------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 1048576
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.disk.smart_size_cached_value: 358400
browser.places.smartBookmarksVersion: 4
browser.sessionstore.upgradeBackup.latestBuildID: 20130821050136
browser.startup.homepage_override.buildID: 20130821050136
browser.startup.homepage_override.mstone: 26.0a1
browser.tabs.warnOnClose: false
dom.mozApps.runUpdate: false
dom.mozApps.used: true
dom.w3c_touch_events.expose: false
extensions.lastAppVersion: 26.0a1
font.language.group: zh-CN
font.name.monospace.zh-CN: YaHei Consolas Hybrid
font.name.sans-serif.zh-CN: YaHei Consolas Hybrid
font.name.serif.x-western: YaHei Consolas Hybrid
font.name.serif.zh-CN: YaHei Consolas Hybrid
gfx.direct3d.last_used_feature_level_idx: 0
gfx.direct3d.prefer_10_1: true
network.cookie.prefsMigrated: true
places.database.lastMaintenance: 1377136741
places.history.expiration.transient_current_max_pages: 91574
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
plugin.state.java: 0
plugin.state.npdeployjava: 0
plugin.state.nppdf: 0
privacy.sanitize.migrateFx3Prefs: true
security.warn_viewing_mixed: false
storage.vacuum.last.index: 0
storage.vacuum.last.places.sqlite: 1374492976

Graphics
--------

Adapter Description: Intel(R) HD Graphics 3000
Adapter Drivers: igdumd32 igd10umd32 igd10umd32
Adapter RAM: Unknown
ClearType Parameters: DISPLAY1 [ Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 100 ] DISPLAY4 [ Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 200 ]
Device ID: 0x0126
Direct2D Enabled: true
DirectWrite Enabled: true (6.2.9200.16571)
Driver Date: 8-21-2012
Driver Version: 9.17.10.2843
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 10
Vendor ID: 0x8086
WebGL Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 3000 Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote: false
AzureCanvasBackend: direct2d
AzureContentBackend: direct2d
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.10.1 Beta
Version in use: 4.10.1 Beta

NSS
Expected minimum version: 3.15.1 Basic ECC
Version in use: 3.15.1 Basic ECC

NSSSMIME
Expected minimum version: 3.15.1 Basic ECC
Version in use: 3.15.1 Basic ECC

NSSSSL
Expected minimum version: 3.15.1 Basic ECC
Version in use: 3.15.1 Basic ECC

NSSUTIL
Expected minimum version: 3.15.1
Version in use: 3.15.1
Flags: needinfo?(wanliyou)
It shall be related to GFX or HW acceleration, but it doesn't crash often at FX24 stage.

https://crash-stats.mozilla.com/report/index/abaaa1a2-a13c-41ad-a466-04ac62130822
https://crash-stats.mozilla.com/report/index/abaaa1a2-a13c-41ad-a466-04ac62130822
No crash for me either on 26.0a2 (2013-09-30), Win 7.
Could you also please check to reproduce the problem:
1. using Firefox in safe mode (with your addons disabled):
http://support.mozilla.com/kb/Safe+Mode

2. On a new, empty profile:
http://support.mozilla.org/en-US/kb/Managing-profiles#w_starting-the-profile-manager
Flags: needinfo?(wanliyou)
Got a random out of the blue crash with this signature on Win64 7 FX24 when a non-PDF web page was loading.  I couldn't reproduce it though.

https://crash-stats.mozilla.com/report/index/4721d484-e41e-4652-a6d2-1e98a2131016
It doesn't crash much in safe mode, but still hit one.

https://crash-stats.mozilla.com/report/index/39afd774-0f12-49b9-9b58-601fe2131017
Flags: needinfo?(wanliyou)
Yet another one. It doesn't have the same signature as the original bug reports though.
https://crash-stats.mozilla.com/report/index/9429a529-15f8-426e-aafc-f48ee2131017
Perhaps you can provide another URL where this is 100% reproducible
In safe mode, HWA is disabled. So the crashes are probably here.

Did you update your Intel drivers?
(In reply to Paul Silaghi, QA [:pauly] from comment #12)
> Perhaps you can provide another URL where this is 100% reproducible

Finally, just find a page that constantly crashes my browser: http://nodeos.github.io/
I did noticed there is a biiiiiiig image on that page which made me thinking if it's due to the large texture size?
https://crash-stats.mozilla.com/report/index/bp-76b5c6b9-92b9-461f-bb52-118362131022
(In reply to Loic from comment #13)
> In safe mode, HWA is disabled. So the crashes are probably here.
> 
> Did you update your Intel drivers?

I think it's the latest WHQL driver from Intel (Thinkpad X220)
(In reply to WL from comment #14)
> Finally, just find a page that constantly crashes my browser:
> http://nodeos.github.io/
Can't reproduce on FF 27.0a1 2013-10-21 Win 7 x64
(In reply to WL from comment #15)
> (In reply to Loic from comment #13)
> > In safe mode, HWA is disabled. So the crashes are probably here.
> > 
> > Did you update your Intel drivers?
> 
> I think it's the latest WHQL driver from Intel (Thinkpad X220)

The latest for Intel® HD graphics Driver for Windows 7 is 15.28.18.64.3223 (8/18/2013), maybe you could try to update yours.


Can you test with HWA disabled, please.
https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration
I've had 7 crashes in Aurora over the last 5 weeks with this signature. I don't believe Lenovo has released a more recent driver, so I've disabled HWA and will report back in a few weeks whether the crashes have ceased or not.

FWIW, here's the latest crash:

https://crash-stats.mozilla.com/report/index/56bb9365-b2a3-4722-b468-152e72140620

And my graphics info from about:support:

Adapter Description	Intel(R) HD Graphics 3000
Adapter Drivers	igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
Adapter RAM	Unknown
Device ID	0x0126
Direct2D Enabled	true
DirectWrite Enabled	true (6.2.9200.16571)
Driver Date	8-21-2012
Driver Version	9.17.10.2843
GPU #2 Active	false
GPU Accelerated Windows	13/13 Direct3D 11 (OMTC)
Vendor ID	0x8086
WebGL Renderer	Google Inc. -- ANGLE (Intel(R) HD Graphics 3000 Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote	true
AzureCanvasBackend	direct2d
AzureContentBackend	direct2d
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0
Andy, your Intel drivers are old, you should try to update them.
The last ones are https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=23763&lang=eng (4/10/2014, 15.28.22.3517)
(In reply to Loic from comment #19)

I've actually tried to update the drivers in the past, but the Intel installer always quit and directed me to the OEM (Lenovo) for their latest customized drivers (which are ancient). I just ran Intel's online update check and it again told me:

"A customized computer manufacturer driver is installed on your computer. The Intel Driver Update Utility is not able to update the driver. Installing a generic Intel driver instead of the customized computer manufacturer driver may cause technical issues. Contact your computer manufacturer for the latest driver for your computer."

It's been a few months since I last ignored that warning and tried Intel's installer, so I just pulled down the latest (actually v 15.28.22.64.3517, since this is a 64-bit OS) and ran it. Lo and behold it seems to have installed!

I'll cross my fingers and try to reboot this machine tonight. Assuming it boots, I'll reenable Hardware Acceleration and monitor for a few more weeks.

I've been using this machine far less than normal over the last 2 weeks (took a vacation) but just for the record there haven't been any crashes with this bug's signature since I disabled HWA on 6/24. I would not consider that proof by any stretch (no STR, relatively short time monitoring for a random crash), but it's at least consistent with the hypothesis that HWA is involved.
I officially don't get Intel's versioning. After running their (not Lenovo's) latest driver installer, only the final number in the driver version changed (from 2843 to 3517).

At any rate, HWA is reenabled.

For posterity, this is my current UA:

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0

... and Graphics info:

Adapter Description	Intel(R) HD Graphics 3000
Adapter Drivers	igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
Adapter RAM	Unknown
Device ID	0x0126
Direct2D Enabled	true
DirectWrite Enabled	true (6.2.9200.16571)
Driver Date	3-20-2014
Driver Version	9.17.10.3517
GPU #2 Active	false
GPU Accelerated Windows	11/11 Direct3D 10
Vendor ID	0x8086
WebGL Renderer	Google Inc. -- ANGLE (Intel(R) HD Graphics 3000 Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote	false
AzureCanvasBackend	direct2d
AzureContentBackend	direct2d
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0
@Andy: If you know some websites where Firefox crashes, can you test again, please.

@WL: did you meet the crashes again? Did you update your graphics driver?
Flags: needinfo?(wanliyou)
Opening several pages of report data (large tables) in background tabs while scrolling through another complex page in Salesforce.com seemed to potentially be the trigger, but that's also typical of my work life and could just be luck or observation bias.

I've also had several crashes with other signatures that, per the related bugs, appear to be caused by the new cycle collector (which I believe was just disabled in 32), so I may be misremembering which crash was which.

If I get another crash with this signature I'll try to get better info about exactly which pages I was interacting with and/or opening at the time. Even in that produces a repeatable test case on my end, though, if it involves Salesforce.com then I won't be able to give others viable STR.
I reproduced the crash on Firefox 33 RC on Windows 7 32bit. Here is the crash report: https://crash-stats.mozilla.com/report/index/bp-9e49b52e-6507-4251-9f52-ece542141008 .

I had many sites opened (Facebook, Youtube, Yahoo Mail, Pinterest, Google Play) and when I opened and navigated on Google Maps (on street view), crash occured. I don't have proper STR. 

In the last week 3001 crashes occured with this signature.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Bas, is this one of the OOMs we know about?
Flags: needinfo?(bas)
(In reply to Milan Sreckovic [:milan] (PTO 10/16-10/17) from comment #25)
> Bas, is this one of the OOMs we know about?

Not to my knowledge.
Flags: needinfo?(bas)
I turned hardware acceleration back on yesterday and it looks like it's causing out of memory issues:

https://crash-stats.mozilla.com/report/index/7f183587-86d2-45e2-b501-fe2c72141028

This was on the Aurora 35.0a2 (2014-10-27) build. Here's my current graphics info from about:support...

Adapter Description	Intel(R) HD Graphics 3000
Adapter Drivers	igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
Adapter RAM	Unknown
Device ID	0x0126
Direct2D Enabled	true
DirectWrite Enabled	true (6.2.9200.16571)
Driver Date	3-20-2014
Driver Version	9.17.10.3517
GPU #2 Active	false
GPU Accelerated Windows	21/21 Direct3D 11 (OMTC)
Subsys ID	21ce17aa
Vendor ID	0x8086
WebGL Renderer	Google Inc. -- ANGLE (Intel(R) HD Graphics 3000 Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote	true
AzureCanvasBackend	direct2d
AzureContentBackend	direct2d 1.1
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0

According to Intel's website, that's the latest driver.

That crash was actually the second time today that the browser content area went black, but I think I sidestepped an imminent crash the first time by having Aurora restart to apply the pending 10-27 update from yesterday.

Unfortunately, I still have no consistent steps to reproduce beyond "Open a ton of complex pages in a ton of tabs and generally abuse Firefox all day."
This hardware has generally caused us problems with the recent changes, but usually not with the latest driver.
Flags: needinfo?(jmuizelaar)
Crash Signature: [@ igd10umd32.dll@0x1fcfb9 ] → [@ igd10umd32.dll@0x1fcfb9 ] [@ igd10umd32.dll@0x1fd0b9 ]
Crash Signature: [@ igd10umd32.dll@0x1fcfb9 ] [@ igd10umd32.dll@0x1fd0b9 ] → [@ igd10umd32.dll@0x1fcfb9 ] [@ igd10umd32.dll@0x1fd0b9 ] [@ igd10umd32.dll@0x1fd399 ] [@ igd10umd32.dll@0x1fb1d9 ]
Here is a recent crash report in 34.0b8: https://crash-stats.mozilla.com/report/index/d2bcc130-4d79-4c45-9a20-3428c2141112

Maybe this crash should be in Graphics:Layers?



crashing thread: 

0 	igd10umd32.dll 	igd10umd32.dll@0x1fcfb9 	
1 	d3d10_1core.dll 	CBaseResource<ID3D10Texture1D, 2>::FinalConstruct(D3D10DDIARG_CREATERESOURCE const&, SD3D10SharedResourceCreationArgs const*, D3D10DDI_HRTRESOURCE) 	
2 	d3d10_1core.dll 	CTexture2D<3>::FinalConstruct(STexture2DConstructorArgs const&) 	
3 	d3d10_1core.dll 	CLayeredObject<CTexture2D<2> >::CreateInstance(STexture2DConstructorArgs const&, void*, void*, _GUID const&, void**) 	
4 	d3d10_1core.dll 	CDevice::CreateLayeredChild(unsigned int, void const*, unsigned long, ILayeredUseCounted*, _GUID const&, void**) 	
5 	d3d10_1core.dll 	CBridgeImpl<IDXGILayeredDevice, IDXGILayeredDevice, CLayeredObject<CDevice> >::CreateLayeredChild(unsigned int, void const*, unsigned long, ILayeredUseCounted*, _GUID const&, void**) 	
6 	dxgi.dll 	CD3D10LayeredChild<ID3D10DeviceChild, CD3D10Device, 64>::FinalConstruct(ED3D10DeviceChildType, SLayeredArgs const*, unsigned long, ILayeredUseCounted*, _GUID const&) 	
7 	dxgi.dll 	CD3D10DeviceChild<IDXGIResource>::FinalConstruct(ED3D10DeviceChildType, SLayeredArgs const*, unsigned long, ILayeredUseCounted*) 	
8 	dxgi.dll 	CD3D10Resource::FinalConstruct(CD3D10Resource::TConstructorArgs const&) 	
9 	dxgi.dll 	CLayeredObject<CD3D10Resource>::CreateInstance(CD3D10Resource::TConstructorArgs const&, void*, void*, _GUID const&, void**) 	
10 	dxgi.dll 	CD3D10Resource::LUCCompleteLayerConstruction()
WL's most recent crashes:

bp-0d423285-180d-4981-8afd-ea8a62150212	 NS_CycleCollectorSuspect3 

bp-fc5b34d9-8a43-4ae5-a1fe-ca8c82150205	 igd10umd32.dll@0x1fcfb9  

bp-839ec228-3453-4ab6-95eb-1d09e2150204 mozilla::layers::YCbCrImageDataSerializer::InitializeBufferInfo(unsigned int, unsigned int, unsigned int, unsigned int, unsigned int, mozilla::gfx::IntSizeTyped<mozilla::gfx::UnknownUnits> const&, mozilla::gfx::IntSizeTyped<mozilla::gfx::UnknownUnits> ...  

bp-96b3a09e-c994-4603-8112-116e72150203	  mozilla::layers::ChromeProcessController::InitializeRoot()
Flags: needinfo?(wanliyou)
WL writes "I still use Firefox nightly, it doesn't crash like this once I have the gfx driver upgraded. But I'm not 100% sure if it's the root cause."
This is our #1 crash in the Intel driver accounting for 38.19% of crashes in igd10umd32.dll:
> igd10umd32.dll@0x1fcfb9: 2833 crashes (24.81%)
> igd10umd32.dll@0x1fd0b9: 775 crashes (6.79%) 
> igd10umd32.dll@0x1fd399: 355 crashes (3.11%)
> igd10umd32.dll@0x1fb1d9: 397 crashes (3.48%)

100% of the crashes are on Windows 7 32-bit
 47% of the crashes are on Intel driver version 9.17.10.28.43
 35% of the crashes are on Intel Xeon E3-1200 v2/3rd Gen Core processor GPU

Top drivers:
9.17.10.2843: 2057 crashes (47%) 
9.17.10.2828: 679 crashes (16%)
9.17.10.2817: 366 crashes (8%)
9.17.10.2857: 312 crashes (7%)

Given the impact on Intel users I suggest we just blacklist these old driver versions, particularly if this can be worked around by using the latest Intel driver.
Can you tell (from telemetry perhaps?) how many people would be affected by blacklisting <= 2843?
Flags: needinfo?(anthony.s.hughes)
(In reply to Bas Schouten (:bas.schouten) from comment #33)
> Can you tell (from telemetry perhaps?) how many people would be affected by
> blacklisting <= 2843?

It's hard to say for sure. I cross referenced the driver versions from Socorro for *all* crashes with the data in David Anderson's telemetry dashboard. From this data it looks like 459,836 of 1,615,006 sessions (28.47%) are using Intel 9.17.10.2843 or older. I think it's safe to assume that the actual number of users affected is some order of magnitude greater.
Flags: needinfo?(anthony.s.hughes)
Crash volume for signature 'igd10umd32.dll@0x1fcfb9':
 - nightly(version 50):0 crashes from 2016-06-06.
 - aurora (version 49):0 crashes from 2016-06-07.
 - beta   (version 48):0 crashes from 2016-06-06.
 - release(version 47):4 crashes from 2016-05-31.
 - esr    (version 45):41 crashes from 2016-04-07.

Crash volume on the last weeks:
            W. N-1  W. N-2  W. N-3  W. N-4  W. N-5  W. N-6  W. N-7
 - nightly       0       0       0       0       0       0       0
 - aurora        0       0       0       0       0       0       0
 - beta          0       0       0       0       0       0       0
 - release       0       0       0       0       0       1       2
 - esr           0       0       0       0       0       4       8

Affected platform: Windows
Closing because no crash reported since 12 weeks.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.