Closed Bug 905955 Opened 7 years ago Closed 7 years ago

B2G RIL: mms data connection does not get disconnected

Categories

(Core :: DOM: Device Interfaces, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla26
blocking-b2g leo+
Tracking Status
firefox24 --- wontfix
firefox25 --- wontfix
firefox26 --- fixed
b2g18 --- fixed
b2g18-v1.0.0 --- wontfix
b2g18-v1.0.1 --- wontfix
b2g-v1.1hd --- fixed

People

(Reporter: jessica, Assigned: jessica)

References

Details

Attachments

(3 files)

Attached file logcat.log
MMS can be sent sucesfully, but the mms data connection remains connected, and it's treated as the default connection.

From the attached log, default route is set for rmnet1 (emome).
08-16 16:44:11.021 I/Gecko   (  143): -*- NetworkManager: Going to change route and DNS to rmnet1
08-16 16:44:11.031 I/Gecko   (  143): Network Worker: received message: {"cmd":"setDefaultRouteAndDNS","ifname":"rmnet1","oldIfname":"rmnet0","gateway_str":"10.38.243.129","dns1_str":"10.1.7.1","dns2_str":"10.1.7.2"}

I can reproduce it 100%, will further confirm with other peers.
Is it reproduced with Moz RIL or QC RIL?
I use Buri for testing/development, so it should be QC RIL, right?
Vicamo found out that some of the properties in RILNetworkInterface are treated as "static", I will try to fix them and see if it solves the problem.
Mozilla RIL is the RIL built from mozilla-central, and QC RIL is the RIL built by QC instead.
I saw some QCRIL keywords in the log, that's why I asked to confirm.

If the code is built by you instead of using a production image, then it must be Mozilla RIL.
Yes, I built it myself from the source code cloned from mozilla-b2g (master branch).
Will there be any difference between the ril built by us (Mozilla RIL) and  the ril built by QC (QC RIL)?

Thanks.
We cannot fix the bug if it's QC RIL, since we don't have the source code.
I get it now. Thanks for the explanation.
connectedTypes was initialized in RILNetworkInterface.prototype, so it was treated as "static". This led to mms's RILNetworkInterface also had "default" in its connectedTypes when default data was connected.
Attachment #792734 - Flags: review?(vyang)
Comment on attachment 792734 [details] [diff] [review]
fix mms not disconnected patch

Review of attachment 792734 [details] [diff] [review]:
-----------------------------------------------------------------

Thank you!
Attachment #792734 - Flags: review?(vyang) → review+
Assignee: nobody → jjong
https://hg.mozilla.org/mozilla-central/rev/25721ca5b28d
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
Duplicate of this bug: 907156
Attached patch b2g18 patchSplinter Review
I second the leo nomination. The attached patch fixed the bug on my 1.1 device.

Some vars have been renamed so asking review to make sure it's correct (but I think it is).
Attachment #793487 - Flags: review?(vyang)
Attachment #793487 - Attachment description: b2g8 patch → b2g18 patch
blocking-b2g: leo? → leo+
Attachment #793487 - Flags: review?(vyang) → review+
You need to log in before you can comment on or make changes to this bug.