Closed Bug 906039 Opened 8 years ago Closed 8 years ago

"New Guest Session" doesn't deserve a toplevel menu item

Categories

(Firefox for Android Graveyard :: General, defect)

All
Android
defect
Not set
normal

Tracking

(firefox25 verified, firefox26 verified, firefox27 verified, fennec25+)

VERIFIED FIXED
Firefox 27
Tracking Status
firefox25 --- verified
firefox26 --- verified
firefox27 --- verified
fennec 25+ ---

People

(Reporter: lucasr, Assigned: mfinkle)

References

Details

Attachments

(1 file)

It's unlikely that it will be used very often by most users. Move it under 'Tools' maybe?

Thoughts?
On the other hand, once you're in a guest session, I do think it makes sense to have a toplevel menu item to exit.
I could see us doing that in a world where we had a better first run / tip experience built into Firefox where we could tell people about it. 

Let's leave it in the menu for now, but I agree we might want to reprioritize its position down the road.
I talked to Ian on IRC and we seem OK to move the menu to a child of Tools. This patch moves the "New Guest Session" to "Tools" but leaves the "Exit Guest Session" as a top level menu.
Assignee: nobody → mark.finkle
Attachment #809159 - Flags: review?(bnicholson)
Attachment #809159 - Flags: review?(bnicholson) → review+
This is primary UI for guest browsing and should get uplifted to fx25
tracking-fennec: --- → 25+
Comment on attachment 809159 [details] [diff] [review]
move-guest-session-tools

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: We'd end up flipping the UI in the next release and get user confused
Testing completed (on m-c, etc.): landed on fx-team
Risk to taking this patch (and alternatives if risky): low risk, just moved the menu
String or IDL/UUID changes made by this patch: none
Attachment #809159 - Flags: approval-mozilla-beta?
Attachment #809159 - Flags: approval-mozilla-aurora?
Comment on attachment 809159 [details] [diff] [review]
move-guest-session-tools

approving for uplift so there's no user confusion.
Attachment #809159 - Flags: approval-mozilla-beta?
Attachment #809159 - Flags: approval-mozilla-beta+
Attachment #809159 - Flags: approval-mozilla-aurora?
Attachment #809159 - Flags: approval-mozilla-aurora+
Comment on attachment 809159 [details] [diff] [review]
move-guest-session-tools

I was too quick - let's wait for this to get merged to central and then, if no unexpected surprises, it's a low risk fix and good to maintain UI consistency.
Attachment #809159 - Flags: approval-mozilla-beta?
Attachment #809159 - Flags: approval-mozilla-beta+
Attachment #809159 - Flags: approval-mozilla-aurora?
Attachment #809159 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/53661597ccbf
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 27
Attachment #809159 - Flags: approval-mozilla-beta?
Attachment #809159 - Flags: approval-mozilla-beta+
Attachment #809159 - Flags: approval-mozilla-aurora?
Attachment #809159 - Flags: approval-mozilla-aurora+
Status: RESOLVED → VERIFIED
Verified fixed on:
Build: Firefox for Android 25 Beta 6 (2013-10-08) and Firefox for Android 26 Aurora (2013-10-08)
Device: Samsung Galaxy Nexus
OS: Android 4.1.1
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.