pymake mochitest-* fails with runtests.py: error: no such option: --build-info-json

RESOLVED FIXED in mozilla26

Status

Testing
Mochitest
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: jimm, Assigned: ahal)

Tracking

({regression})

Trunk
mozilla26
x86_64
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Comment hidden (empty)
(Reporter)

Comment 1

5 years ago
$ pymake mochitest-metro-chrome
make.py[0]: Entering directory 't:\Mozilla\MC-REL'
t:\Mozilla\mc\browser\build.mk:53:0$ rm -f ./mochitest-metro-chrome.log && t:/Mozilla/MC-REL/_virtualenv/Scripts/python.exe _tests/testing/mochitest/runtests.py --autorun --close-w
hen-done --console-level=INFO --log-file=./mochitest-metro-chrome.log --file-level=INFO --failure-file=t:/Mozilla/MC-REL/_tests/testing/mochitest/makefailures.json --testing-module
s-dir=t:/Mozilla/MC-REL/_tests/modules --extra-profile-file=./dist/plugins --build-info-json=t:/Mozilla/MC-REL/./mozinfo.json --symbols-path=./dist/crashreporter-symbols   --metro-
immersive --browser-chrome
Usage: Usage instructions for runtests.py.
    All arguments are optional.
    If --chrome is specified, chrome tests will be run instead of web content tests.
    If --browser-chrome is specified, browser-chrome tests will be run instead of web content tests.
    See <http://mochikit.com/doc/html/MochiKit/Logging.html> for details on the logging levels.


runtests.py: error: no such option: --build-info-json
t:\Mozilla\mc\browser\build.mk:53:0: command 'rm -f ./mochitest-metro-chrome.log && t:/Mozilla/MC-REL/_virtualenv/Scripts/python.exe _tests/testing/mochitest/runtests.py --autorun
--close-when-done --console-level=INFO --log-file=./mochitest-metro-chrome.log --file-level=INFO --failure-file=t:/Mozilla/MC-REL/_tests/testing/mochitest/makefailures.json --testi
ng-modules-dir=t:/Mozilla/MC-REL/_tests/modules --extra-profile-file=./dist/plugins --build-info-json=t:/Mozilla/MC-REL/./mozinfo.json --symbols-path=./dist/crashreporter-symbols
 --metro-immersive --browser-chrome' failed, return code 2
Blocks: 868158
Looks like Bug 903034 removed the --build-info-json option again, not sure why.
Blocks: 903034
Keywords: regression
(Reporter)

Updated

5 years ago
Summary: pymake mochitest-metro-chrome fails with runtests.py: error: no such option: --build-info-json → pymake mochitest-* fails with runtests.py: error: no such option: --build-info-json
(Reporter)

Comment 3

5 years ago
Created attachment 791690 [details] [diff] [review]
add back build-info-json
(Reporter)

Comment 4

5 years ago
Comment on attachment 791690 [details] [diff] [review]
add back build-info-json

(In reply to Frank Wein [:mcsmurf] from comment #2)
> Looks like Bug 903034 removed the --build-info-json option again, not sure
> why.

Not sure, but adding it back fixes this bug.
Attachment #791690 - Flags: review?(jgriffin)
(Assignee)

Comment 5

5 years ago
Created attachment 792195 [details] [diff] [review]
remove build info json from mochitest make targets

Sorry, I didn't realize there were make targets still using this. There was a change in bug 903034 that should make --build-info-json unnecessary. Jim, does this patch work for you? If not then I don't mind just taking your patch for the time being.
Flags: needinfo?(jmathies)
(Assignee)

Comment 6

5 years ago
Comment on attachment 792195 [details] [diff] [review]
remove build info json from mochitest make targets

Just verified the above patch fixes the problem for me. I'll get Jonathan to review while waiting for confirmation from Jim.

On a side note, while make targets are still supported, mach commands are the recommended way to run tests. To get around this problem in the meantime, you can either apply this patch, or just use ./mach mochitest-plain, etc..
Attachment #792195 - Flags: review?(jgriffin)
(Assignee)

Updated

5 years ago
Attachment #791690 - Flags: review?(jgriffin)
(Reporter)

Comment 7

5 years ago
Yes this appears to address the problem as well.
Flags: needinfo?(jmathies)
Attachment #792195 - Flags: review?(jgriffin) → review+
(Assignee)

Comment 8

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/0d80c3668110
Assignee: nobody → ahalberstadt
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/0d80c3668110
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
You need to log in before you can comment on or make changes to this bug.