Remove testing for "Automatic updates" on release builds

RESOLVED FIXED in Firefox 25

Status

()

Firefox for Android
General
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: philor, Assigned: liuche)

Tracking

25 Branch
Firefox 26
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox24 unaffected, firefox25 fixed, firefox26 fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
https://tbpl.mozilla.org/?tree=Try&rev=708ead144572 is current aurora pushed to try as though it were on beta. Note the rc2 failures, https://tbpl.mozilla.org/php/getParsedLog.php?id=26415724&tree=Try, where testSettingsMenuItems is trying to find the "Automatic updates" section which doesn't exist because on beta and below the custom updater is shut off.
Summary: testSettingsMenuItems will fail when 25 hits mozilla-beta → Remove testing for "Automatic updates" on release builds
Created attachment 793185 [details] [diff] [review]
Patch: Remove testing for "Automatic updates" on release builds

Try build (with patch from bug 903535, which needs something similar): https://tbpl.mozilla.org/?tree=Try&rev=b0d95219d095

I just added some build flag checks to the test, not sure if this is the right way to do branch-specific testing.
Attachment #793185 - Flags: feedback?(gbrown)
QA Contact: liuche
Assignee: nobody → liuche
QA Contact: liuche
Attachment #793185 - Flags: feedback?(gbrown)
Philor, what's the case where the Automatic updates setting is hidden? Your try pushes show "late beta" but I'd like to confirm that this is for all beta and release.
Flags: needinfo?(philringnalda)
(Reporter)

Comment 3

4 years ago
It changes when the branding changes (EARLY_BETA_OR_EARLIER was just the tipmost thing in that try push, https://hg.mozilla.org/try/rev/c8d5855a9572 was the part that changed branding), both http://mxr.mozilla.org/mozilla-aurora/source/mobile/android/branding/beta/configure.sh and http://mxr.mozilla.org/mozilla-aurora/source/mobile/android/branding/official/configure.sh unset MOZ_UPDATER.
Flags: needinfo?(philringnalda)
Created attachment 794772 [details] [diff] [review]
Patch: Remove testing for auto-update when not built

This patch depends on the patches from bug 900564 for conditional tests.
Attachment #793185 - Attachment is obsolete: true
Attachment #794772 - Flags: review?(gbrown)
Depends on: 900564
Green try build when Automatic updates are not built: https://tbpl.mozilla.org/?tree=Try&rev=8e1023fe869f
low risk uplift when ready with risk evaluation and user impact should be good enough.Need not track it.
tracking-firefox25: ? → ---

Updated

4 years ago
Attachment #794772 - Flags: review?(gbrown) → review+
https://hg.mozilla.org/integration/fx-team/rev/092d8cc931f8
Status: NEW → ASSIGNED
Target Milestone: --- → Firefox 26
https://hg.mozilla.org/mozilla-central/rev/092d8cc931f8
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Created attachment 796307 [details] [diff] [review]
Aurora patch: remove testing for auto updates

Unless we want to uplift the test changes [1] from bug 900564, using #ifdefs seems like the most straightforward way to do conditional testing.

[1] https://hg.mozilla.org/mozilla-central/rev/7b5fe881c650
Attachment #796307 - Flags: review?(gbrown)

Updated

4 years ago
Attachment #796307 - Flags: review?(gbrown) → review+
Comment on attachment 796307 [details] [diff] [review]
Aurora patch: remove testing for auto updates

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Automatic updates is not built on beta/release
User impact if declined: Robocop testSettingsMenuItems will fail when 25 merges to beta
Testing completed (on m-c, etc.): locally tested
Risk to taking this patch (and alternatives if risky): low - just checks for a single declaration of a build flag
String or IDL/UUID changes made by this patch: none
Attachment #796307 - Flags: approval-mozilla-aurora?
Attachment #796307 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Landed on aurora: https://hg.mozilla.org/releases/mozilla-aurora/rev/6ec4a999aa87
status-firefox25: affected → fixed
status-firefox26: affected → fixed
You need to log in before you can comment on or make changes to this bug.