Blocking ads from directories

RESOLVED DUPLICATE of bug 78104

Status

()

Core
Image Blocking
--
enhancement
RESOLVED DUPLICATE of bug 78104
17 years ago
15 years ago

People

(Reporter: Torsten Rueger, Assigned: Mitchell Stoltz (not reading bugmail))

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12 i686)
BuildID:    2001062823

I have set mozialla up to block images, to be able to block ads.
Sometimes the ad image is on the original server, and I can't block this.
So I would loke to be able to block images from a directory, by right
mouseclick.

Reproducible: Always
Steps to Reproduce:
1.Go to http://dict.leo.org/
2. Top right has an ad, I want to get rid of it.
3. Right click image


Actual Results:  I only get "Block images from server"

Expected Results:  I need something like "block images from this directory"

Comment 1

17 years ago
.
Assignee: mpt → morse
Component: User Interface Design → Cookies
QA Contact: zach → tever

Comment 2

17 years ago
There might be a bit of a confusion here.  The menu item "block images from this 
server" refers to the server that delivered the image and not the server that 
delivered the page being viewed.  So you can block any image that you can see on 
the page, plus all other images that are delivered from the same servers that 
delivered those images.

If that answer doesn't satisfy you, then please be more specific.  In 
particular, what do you mean by "this directory"?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 3

17 years ago
-> xp GUI has adblocking (I think...)

REOPEN:
I think this person is asking for blocking graphics on a URL prefix basis. Does
the current feature work by hostname:port?

For example:

"block all ads from <http://site/adimages/*>"
Status: RESOLVED → UNCONFIRMED
Component: Cookies → XP Apps: GUI Features
Resolution: INVALID → ---

Updated

17 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → Future

Updated

17 years ago
Summary: Blocking adds from directories → Blocking ads from directories

Comment 4

17 years ago
This is basically an extension of bug 33576. I hadn't considered it in my 
dialog design for that bug, but it would just be a matter of adding extra radio 
buttons for each level of URL hierarchy.
Depends on: 33576
OS: Linux → All
Hardware: PC → All
(Reporter)

Comment 5

17 years ago
What was said by Benjamin hits my point.

The user interface for this could appear in the right mouse click menu as a
seperate point: "Block images from this server direcory".

Or you could launch a dialog asking wheather the user wants all images blocked
or just from this directory (or even let us type regular expressions, both for
the image directory, and the link where it goes. New ideas all the time)

But seriously, I'd be happy if you get this in, even its "only" a feature
request and not a bug.

I just read the 33576 bug. I have nothing to add. You can close this as far as I
am concerned.
Reassigning to new module owner.
Assignee: morse → mstoltz
Status: ASSIGNED → NEW
Component: XP Apps: GUI Features → Image Blocking

Comment 7

15 years ago
Well, I just voted for this one, because I have been really, really wanting the
capability, but then I came across bug
http://bugzilla.mozilla.org/show_bug.cgi?id=78104.  Is this one not a dupe (or a
subset) of that one?

Comment 8

15 years ago
-> default qa

Updated

15 years ago
QA Contact: tever → nobody

Comment 9

15 years ago
Isn't this a duplicate/subset of bug 78104?
(Assignee)

Comment 10

15 years ago

*** This bug has been marked as a duplicate of 78104 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.