Closed Bug 906359 Opened 10 years ago Closed 9 years ago

Rename "fullName" key to "title" in package.json

Categories

(Add-on SDK Graveyard :: General, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED FIXED
mozilla28

People

(Reporter: zombie, Assigned: zombie)

Details

Attachments

(1 file, 1 obsolete file)

After a discussion with Gozala about key naming conventions/consistency in Add-on SDK, and package.json in particular, `fullName` was found to be against the intended `dashes-in-key-names` policy.

And once it was decided that we will go ahead with the renaming, a key name even more appropriate than `full-name` was found: `title`.
P3, patches accepted. It'd need to maintain support for the older name so addons don't break.
Priority: -- → P3
with this patch, addon SDK uses 'title' key from package.json for the addon name. if not present, it falls back to the old 'fullName' key (no addon should fail to build with this change).

updated several existing tests and examples.

not sure if a something as simple as this needs tests, so the 3 new ones are separated in their own commit (for easy inclusion/exclusion).

i considered adding a warning for addons without the new key, but since the renaming is fully transparent and backward-compatible, the warning should probably wait until after this is deployed, and then documented, and maybe even a version or two after that..


btw, you can assign the bug to me..
Attachment #822685 - Flags: review?(kwierso)
Comment on attachment 822685 [details] [review]
Link to pull request 1272

I'm not an SDK reviewer, passing this on to Dave for him to find someone to do it.
Attachment #822685 - Flags: review?(kwierso) → review?(dtownsend+bugmail)
Comment on attachment 825521 [details]
Pointer to Github pull request: https://github.com/mozilla/addon-sdk/pull/1272

Oops
Attachment #825521 - Attachment is obsolete: true
Attachment #822685 - Flags: review?(dtownsend+bugmail) → review+
Commits pushed to master at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/3519f268ea051e4ea0019bbd20fb0d47ff507554
bug 906359 - rename fullName key to title

with fallback for the old key name..

https://github.com/mozilla/addon-sdk/commit/4c2a5f354ff9cc7d6cc66a3a1e4b96005d0c1429
bug 906359 - update tests, examples to use title

https://github.com/mozilla/addon-sdk/commit/ae8dd440f3e2b9132889a29225f6e7433286ac04
bug 906359 - add tests for the rename, fallback

https://github.com/mozilla/addon-sdk/commit/6e82496fa6415466a433dddc37f14460393f5dd7
Merge pull request #1272 from zombie/906359-rename-fullName

Bug 906359: rename fullName key to title in package.json. r=Mossop
Merged
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
You need to log in before you can comment on or make changes to this bug.