Closed Bug 906405 Opened 7 years ago Closed 6 years ago

SVG marker causes rendering to stop

Categories

(Core :: SVG, defect)

23 Branch
x86_64
All
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox29 --- affected
firefox30 --- affected
firefox31 --- affected
firefox32 --- affected
firefox-esr24 --- affected

People

(Reporter: bugzilla-mozilla, Unassigned)

References

Details

(Keywords: regression)

Attachments

(3 files)

Attached file website.tar.gz
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130806211916

Steps to reproduce:

user agent: Mozilla/5.0 (X11; Linux x86_64; rv:23.0) Gecko/20100101 Firefox/23.0 

Use attached site in a webserver, no modules required. It only uses javascript.
I did not extract the bug for a standalone example.
Open footprint.html, select package "SOIC/SOP", select solder joint "flat ribbon …".


Actual results:

the footprint view is not rendered correctly.
measurement indications are broken and/or missing.


Expected results:

save the page as file, and open the file.
all measurement indications are drawn correctly: SVG drawings seem to be valid. 

javascript soic.js line 485 and 510 sets "marker-start" as attribute or property (both give the same result). If this is commented out, all measurement indications are drawn correctly, but without markers.

additionally, if you click "draw", both package and footprint svg drawings fail to render.
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9f476b4ac1e1&tochange=6b58397ad735


Note:
Zoom-in/Zoom-out then the measurement indications appears.
Blocks: dlbi
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
A minimal testcase would be very helpful.
Keywords: testcase-wanted
I tried to isolate the bug and wrote a small test case (1) where lines with markers are drawn. The bug do not occur in this test case.
The test case has the following properties:
- 2 svgs are use (because in the previous example, the drawing fails only on the second svg)
- the svgs use viewBoxs (this is also the case in the first example)
- the script alternate between drawing horizontal lines with markers, and vertical without (because the first example also draws normal lines).

Since the bug is not present here, there might be other conditions which trigger it, which I don't know.
I just wrote the first web page in my spare time. I am not an web developer at all, and do not know the underlying technology.
Attached file test case 1 (.html)
Attachment #792860 - Attachment mime type: text/plain → text/html
Attached file another tastcase html
This testcase is:
set "display:none" to the SVG element 
and then remove the css property.


function run(){
  var svg = document.getElementById("svg_footprint");
  setTimeout(function(){
    svg.style.setProperty("display", "none", "");
    setTimeout(function(){svg.style.removeProperty("display")}, 0);
  }, 0);
}


Zoom-in/Zoom-out, then the SVG appears.
This is also same regression window.
Assignee: nobody → alice0775
Seems OK now (Firefox 26). Feel free to reopen if you disagree.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
The problem still happen in Firefox26 as well as Nightly29.0a1

STR
1. Open attachment 792923 [details]
2. Ctrl+F5 and repeat Step.2

Actual Results:
FOOTPRINT does not appear sometimes

After zoom-in/out then the image appears.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Hmm, FOOTPRINT always appears for me now although it did disappear in Firefox 25. Does turning off HWA make any difference?
(In reply to Robert Longson from comment #8)
> Hmm, FOOTPRINT always appears for me now although it did disappear in
> Firefox 25. Does turning off HWA make any difference?

Nothing different even if HWA off on Wndows7 x64.
And also the problem happens on Ubuntu12.04 i686(on VMWare Player)

The following  is Graphics section of clean profile:

#1 Windows7 x64

Graphics
--------

Adapter Description: ATI Radeon HD 4300/4500 Series
Adapter Drivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM: 512
ClearType Parameters: Gamma: 2200 Pixel Structure: R ClearType Level: 50 Enhanced Contrast: 50
Device ID: 0x954f
Direct2D Enabled: true
DirectWrite Enabled: true (6.1.7601.18245)
Driver Date: 4-29-2013
Driver Version: 8.970.100.1100
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 10
Vendor ID: 0x1002
WebGL Renderer: Google Inc. -- ANGLE (ATI Radeon HD 4300/4500 Series Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote: false
AzureCanvasBackend: direct2d
AzureContentBackend: direct2d
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0


#2 Ubunto12.04 i686 on VMWare Player
Graphics
--------

Adapter Description: VMware, Inc. -- Gallium 0.4 on SVGA3D; build: RELEASE;
Device ID: Gallium 0.4 on SVGA3D; build: RELEASE;
Driver Version: 2.1 Mesa 8.0.4
GPU Accelerated Windows: 0/1 Basic
Vendor ID: VMware, Inc.
WebGL Renderer: VMware, Inc. -- Gallium 0.4 on SVGA3D; build: RELEASE;
windowLayerManagerRemote: false
AzureCanvasBackend: cairo
AzureContentBackend: cairo
AzureFallbackCanvasBackend: none
AzureSkiaAccelerated: 0


I think you shoud test with clean profile.
If you installed any add-on which is modified layout with CSS such Tree Style Tab, the problem never happens.

And I notice that the image appears when resize browser window.
OS: Linux → All
Assignee: alice0775 → nobody
Still reproduce the problem

https://hg.mozilla.org/mozilla-central/rev/6a984e21c2ca
Mozilla/5.0 (X11; Linux i686; rv:32.0) Gecko/20100101 Firefox/32.0 ID:20140602072051
bug 1063073 should have fixed this. It does work for me now.
Status: NEW → RESOLVED
Closed: 7 years ago6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.