Closed Bug 906439 Opened 8 years ago Closed 8 years ago

about:support should not display the link to about:crashes when crash reporter is disabled

Categories

(Firefox :: Untriaged, defect)

25 Branch
x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 26

People

(Reporter: jidanni, Assigned: glandium)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux i686; rv:25.0) Gecko/20100101 Firefox/25.0 Iceweasel/25.0a2 (Beta/Release)
Build ID: 20130816004007

Steps to reproduce:

In Help > Troubleshooting Information clicked about:crashes out of curiosity.


Actual results:

"The URL is not valid and cannot be loaded."
Is the URL shown? Have you made sure that this is not an issue because of Debian renaming some folder path from Firefox to IceWeasel?
Debian currently disables the crash reporter.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → INVALID
Well then Debian had better take further steps,
as users will still click there!
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INVALID → ---
Summary: Troubleshooting Information about:crashes gives The URL is not valid and cannot be loaded. → about:support should not display the link to about:crashes when crash reporter is disabled
Assignee: nobody → mh+mozilla
Comment on attachment 792051 [details] [diff] [review]
Hide about:crashes link from about:support when building with --disable-crash-reporter

>diff --git a/toolkit/content/Makefile.in b/toolkit/content/Makefile.in

>+ifdef MOZ_CRASHREPORTER
>+DEFINES += -DMOZ_CRASHREPORTER
>+endif

MOZ_CRASHREPORTER is AC_DEFINE()d, so this shouldn't be necessary? r=me with it removed.
Attachment #792051 - Flags: review?(gavin.sharp) → review+
https://hg.mozilla.org/mozilla-central/rev/a68a00ac5c65
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26
You need to log in before you can comment on or make changes to this bug.