Modal window annoyance and browser hanging during login (and user experience issue that comes with it)

RESOLVED DUPLICATE of bug 906442

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 906442
5 years ago
5 years ago

People

(Reporter: mytestmailbox1, Unassigned)

Tracking

23 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130814063812

Steps to reproduce:

I'm using Firefox 23.0.1 under Windows 7 SP1.

Go there and try to file a bug:
https://www.eff.org/https-everywhere/development
It gives a link and lists a login/password pair, currently these are:
cypherpunks/writecode

The page to log in is:
https://trac.torproject.org/projects/tor/report/19
it has 'login' at the top-right.

A modal window appears. Try to log in using cypherpunks/writecode.


Actual results:

As you try to log in with that pair, Firefox hangs and becomes unresponsive.
Also, even though it's an intended behavior for modal windows, I couldn't just copy and paste the login and the password form a different tab.


Expected results:

Just a normal login procedure.

Besides, a modal window like that is a major disruption of users' workflow. You can no longer access you other tabs or menus or toolbars in the same window until you attend to that modal window. Still, you can do everything you want in another Firefox window. It's a very intrusive behavior. I tried to use Chrome to file that bug. Not only it logged me in smoothly but also its prompt for login and password won't prevent you from switching to another tab or using its menu.

It's a frustrating user experience in Firefox. Chrome was just so much more convenient in that regard, sadly. Do I have to copypaste it to Notepad, or drag a tab with login/password so it makes a new window (all in advance)? Or memorize it?
Why loging in using modal window should be a magnitude more disruptive of a normal workflow that logging into ordinary sites?

There's a counterexample, however. If you try out the JS alert function, Firefox will just darken the current page and wait till you click the alert window and won't prevent you from doing anything you want. While Chrome would behave exactly like Firefox does with modal windows.

Being less intrusive is the way to go. The way Firefox currently handles JS alert event is a good idea, or the way Chrome logs you in there.

There's still a nuisance with this site:
http://htmlweb.ru/java/js1.php
It will switch you to its tab to show that stupid message and I want it just to load in the background (both in Firefox and Chrome). Again, not a good idea form user experience perspective.

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 906442
You need to log in before you can comment on or make changes to this bug.