enable hardware keyboard

RESOLVED DUPLICATE of bug 890186

Status

RESOLVED DUPLICATE of bug 890186
5 years ago
5 years ago

People

(Reporter: nguyenthanh.trung, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 792677 [details] [diff] [review]
gecko_enable_hw_keyboard.patch

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/28.0.1500.52 Safari/537.36

Steps to reproduce:

I tried to use hardware keyboard on APC 8950 board.
So I made a patch to Gecko for this.


Actual results:

hardware keyboard did not work


Expected results:

Hardware keyboard should work with the board.
(Reporter)

Updated

5 years ago
OS: All → Gonk (Firefox OS)
(Reporter)

Comment 1

5 years ago
P/S: used Gecko revision is 90926988841e6bebe5482d4dcb886597edacaeae

Updated

5 years ago
See Also: → bug 890186
Hardware keyboard is a complex topic, on the application side we need to ensure keyboard app got a chance to handle these keys (in order to provide spell check, operate Asian IME, for example).

Not sure which version we will be targeting to support hardware keyboard but thanks for filing so we could track it!
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to nguyenthanh.trung from comment #1)
Please refer to bug 890186, it is the same case with this one.
The difference is that the keys are provided by BT HID profile and yours may came from matrix keys or others.

Once bug 890186 is done, both HW keyboard and BT HID profile can send key event to Apps.
Maybe you can join and track the status on bug 890186 together.

Thanks.
(Reporter)

Comment 4

5 years ago
(In reply to Marco Chen [:mchen] from comment #3)
> (In reply to nguyenthanh.trung from comment #1)
> Please refer to bug 890186, it is the same case with this one.
> The difference is that the keys are provided by BT HID profile and yours may
> came from matrix keys or others.
> 
> Once bug 890186 is done, both HW keyboard and BT HID profile can send key
> event to Apps.
> Maybe you can join and track the status on bug 890186 together.
> 
> Thanks.

OK :)
Would you think this could help having hardware keyboard working on HTC Desire Z ?
(Reporter)

Comment 6

5 years ago
(In reply to Alexandre LISSY :gerard-majax from comment #5)
> Would you think this could help having hardware keyboard working on HTC
> Desire Z ?

I think that would. But this fix is applied to the branch gecko-18. You can check bug 890186 for the master branch. Some idea there is pretty the same with this.

Comment 7

5 years ago
Bug 890186 just got checked in. If it works for you, feel free to dup this bug or whatever you prefer. There may be additional things that need to be fixed - I wasn't able to get keys to repeat.
(Reporter)

Comment 8

5 years ago
Okay, I'll check that. thanks! Since we move to master, I also adapted my patch to that branch, but just noticed your comment. Seem keys repeating does not work. However, it works with the old patch in gecko-18.
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 890186
You need to log in before you can comment on or make changes to this bug.