Closed Bug 907101 Opened 7 years ago Closed 7 years ago

Test failure "Certificate's country code is displayed - '(US)' should equal '(US,postalCode=94041,STREET=650 Castro St Ste 300)'" in testGreenLarry.js

Categories

(Mozilla QA Graveyard :: Mozmill Tests, defect, P1)

defect

Tracking

(firefox23 fixed, firefox24 fixed, firefox25 fixed, firefox26 fixed, firefox-esr17 fixed)

RESOLVED FIXED
Tracking Status
firefox23 --- fixed
firefox24 --- fixed
firefox25 --- fixed
firefox26 --- fixed
firefox-esr17 --- fixed

People

(Reporter: AndreeaMatei, Assigned: cosmin-malutan)

References

()

Details

(Whiteboard: [mozmill-test-failure])

Attachments

(1 file, 1 obsolete file)

Started today to fail on Beta, all platforms, with en-US. I can reproduce with Nightly as well, Cosmin will add the fix in bug 905960 as he already was working there on the same test.
OS: Linux → All
Priority: -- → P1
Hardware: x86_64 → All
Assignee: nobody → cosmin.malutan
Status: NEW → ASSIGNED
Summary: Test failure "Certificate's country code is displayed - '(US)' should equal '(US,postalCode=94041,STREET=650 Castro St Ste 300)'" in testGreyLarry.js → Test failure "Certificate's country code is displayed - '(US)' should equal '(US,postalCode=94041,STREET=650 Castro St Ste 300)'" in testGreenLarry.js
How is this related to bug 905960? I do not see the connection between those two bugs. Can you please explain?
As the cert info for https://addons.mozilla.org shows me a new certificate has been issued here. So all branches will be affected. Please handle that separately from bug 905960.
No longer depends on: 905960
Attached patch patch_v1.0 (obsolete) — Splinter Review
This bug is produced because the certificate has been changed, so I had to update a string, so we extract the state correctly from certificate.
http://mozmill-crowd.blargon7.com/#/functional/report/e503b7b0a70a3839c66c64572e8da873
http://mozmill-crowd.blargon7.com/#/functional/report/e503b7b0a70a3839c66c64572e8b6a78
http://mozmill-crowd.blargon7.com/#/functional/report/e503b7b0a70a3839c66c64572e9148a2
Attachment #792803 - Flags: review?(andreea.matei)
Comment on attachment 792803 [details] [diff] [review]
patch_v1.0

Review of attachment 792803 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. Please just quickly update the username and make this patch for default first. Thanks!
Attachment #792803 - Flags: review?(andreea.matei) → review-
Attached patch patch_v1.1Splinter Review
Sorry for that I didn't changed my .hgrc file on mac.
Attachment #792803 - Attachment is obsolete: true
Attachment #792805 - Flags: review?(andreea.matei)
Comment on attachment 792805 [details] [diff] [review]
patch_v1.1

Review of attachment 792805 [details] [diff] [review]:
-----------------------------------------------------------------

Landed on default:
http://hg.mozilla.org/qa/mozmill-tests/rev/59171fbd5f02 (default)

We need backporting, please be aware of the commit message.
Attachment #792805 - Flags: review?(andreea.matei) → review+
It backports cleanly on all branches.
Product: Mozilla QA → Mozilla QA Graveyard
You need to log in before you can comment on or make changes to this bug.