[IMM] Enter key shouldn't commit composing string of ChangJie for WinXP

RESOLVED FIXED in Firefox 43

Status

()

Core
Widget: Win32
RESOLVED FIXED
17 years ago
3 years ago

People

(Reporter: Frank Tang, Assigned: masayuki)

Tracking

({inputmethod})

Trunk
mozilla43
x86
Windows XP
inputmethod
Points:
---

Firefox Tracking Flags

(firefox43 fixed)

Details

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
I can reproduce this on WinNT4J and USWinME w/ Global IME. Not sure about other
platform.
It happen to both ChiangJie and bopomofo (the default) Traditional Chinese IME 
way to reproduce it
1. launch netscape6 composer
2. change IME to tradtional Chinese - say chiang jie IME
3. type 'a', it should bring up the radical 'sun' in precompoes mode. 
4. hit enter. 
expect result :
commit the precomposed text
actual result:
the precomposed text will be hightlight in yellow. and the text before it in the
same line will be reversed. The uesr will feel very confused. The visual
feedback is wrong. No data lost but it will mislead the user.

Updated

17 years ago
QA Contact: andreasb → ylong

Comment 1

17 years ago
accepting and setting the milestone to 0.9.3 to see if I can fix this in time.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.3

Comment 2

17 years ago
Moving milestone to 0.9.4 
Target Milestone: mozilla0.9.3 → mozilla0.9.4
(Reporter)

Comment 3

17 years ago
This looks very bad. 
mark nsbranch but m0.9.5
Keywords: nsbranch
Priority: -- → P2
Target Milestone: mozilla0.9.4 → mozilla0.9.5

Updated

17 years ago
Blocks: 99171

Comment 4

17 years ago
nsbranch- since Frank moved it to 0.9.5
Keywords: nsbranch → nsbranch-

Updated

17 years ago
Target Milestone: mozilla0.9.5 → mozilla0.9.6
(Reporter)

Comment 5

17 years ago
p3 m0.9.7
Priority: P2 → P3
Target Milestone: mozilla0.9.6 → mozilla0.9.7

Comment 6

17 years ago
nsbeta1
Keywords: nsbeta1

Updated

17 years ago
Blocks: 107067

Updated

17 years ago
Keywords: nsbranch-

Updated

17 years ago
Target Milestone: mozilla0.9.7 → mozilla0.9.8

Comment 7

17 years ago
nsbeta1-
 visual effect only
Keywords: nsbeta1 → nsbeta1-

Comment 8

16 years ago
push off 0.9.8 to 0.9.9
Target Milestone: mozilla0.9.8 → mozilla0.9.9

Updated

16 years ago
No longer blocks: 107067
(Reporter)

Comment 9

16 years ago
also happen to simp chinese window. nomitate for nsbeta1 again
Keywords: nsbeta1- → nsbeta1
(Reporter)

Comment 10

16 years ago
nsbeta1- per triage meeting


Keywords: nsbeta1 → nsbeta1-

Updated

16 years ago
Target Milestone: mozilla0.9.9 → mozilla1.0.1

Updated

16 years ago
Target Milestone: mozilla1.0.1 → mozilla1.2beta

Comment 11

16 years ago
bulk milestone change
Target Milestone: mozilla1.2beta → mozilla1.3alpha
QA Contact: amyy → i18n
Keywords: inputmethod
On Win7, Enter key doesn't affect composition state (i.e., nothing happens). This is right behavior.

On WinXP, Enter key commits '日' and inserts an LF. But on the other applications, '日' isn't committed. So, this is a remaining issue. I cannot reproduce this bug when I type two or more characters.
Assignee: tetsuroy → masayuki
Component: Internationalization → Widget: Win32
OS: Windows NT → Windows XP
Priority: P3 → --
QA Contact: i18n → win32
Summary: traditional Chinese IME have problem with RETURN before commit → Enter key shouldn't commit composing string of ChangJie for WinXP
Target Milestone: mozilla1.3alpha → ---
Summary: Enter key shouldn't commit composing string of ChangJie for WinXP → [IMM] Enter key shouldn't commit composing string of ChangJie for WinXP
Created attachment 8649851 [details] [diff] [review]
Cancel composition when Enter key message isn't consumed by IME

Let's cancel composition when Enter key isn't consumed by IME. This is same behavior as IE6.
Attachment #8649851 - Flags: review?(m_kato)
(In reply to Masayuki Nakano (:masayuki) (Mozilla Japan) from comment #12)
> On Win7, Enter key doesn't affect composition state (i.e., nothing happens).
> This is right behavior.
> 
> On WinXP, Enter key commits '日' and inserts an LF. But on the other
> applications, '日' isn't committed. So, this is a remaining issue. I cannot
> reproduce this bug when I type two or more characters.

When I test my Windows XP with New ChangJie 2010, I cannot reproduce this like your say.  Even if hit [Enter] key, '日' isn't committed by the follow.

Step
1. Turn on New ChangJie 2010
2. Focus any input field
3. Type 'a' to input '日'.  Then candidate window shows '日'
4. Hit [Enter]

What IME do you use?
Created attachment 8650295 [details]
screenshot of the property dialog ChangJie on WinXP

It's displayed as just "ChangJie". I cannot see any menu to show its version. I added this from the input language service UI.

And I also reproduce this bug with other Chinese IMEs including simplified Chinese's. I guess that they use same code to handle key and show reading window and candidate window.
Ah, I see, you use *New* ChangJie, the IME having this problem is called just "ChangJie".
(In reply to Masayuki Nakano (:masayuki) (Mozilla Japan) from comment #17)
> Ah, I see, you use *New* ChangJie, the IME having this problem is called
> just "ChangJie".

Where can I get it from?  As zh-tw default, it is Microsoft New Phonetic IME 2002a.
Created attachment 8650310 [details]
Screenshot of intalling ChangJie on WinXP-Ja

Isn't this exiting on your dropdown list of the "add..." UI?
(In reply to Masayuki Nakano (:masayuki) (Mozilla Japan) from comment #19)
> Created attachment 8650310 [details]
> Screenshot of intalling ChangJie on WinXP-Ja
> 
> Isn't this exiting on your dropdown list of the "add..." UI?

Oh, thanks.  I found it.
Comment on attachment 8649851 [details] [diff] [review]
Cancel composition when Enter key message isn't consumed by IME

Review of attachment 8649851 [details] [diff] [review]:
-----------------------------------------------------------------

But if we found a regression, this should be backed out.

Microsoft already provides new IME for Changjie and this seems to be only on XP, and it doesn't occur if using it.
Attachment #8649851 - Flags: review?(m_kato) → review+
And even if this is Microsoft application, the behavior is different when using wordpad (Richedit control).
But I think editbox has correct behavior.  It is as same as IE's behavior.
> But if we found a regression, this should be backed out.

Yeah, in such case, we should mark this as WONTFIX because it's difficult to list up all IMEs which has same trouble.
url:        https://hg.mozilla.org/integration/mozilla-inbound/rev/d0065cf362cfb972084141de6c36067d0b64b89e
changeset:  d0065cf362cfb972084141de6c36067d0b64b89e
user:       Masayuki Nakano <masayuki@d-toybox.com>
date:       Thu Aug 20 17:31:10 2015 +0900
description:
Bug 90712 Cancel composition when Enter key message isn't consumed by IME r=m_kato
https://hg.mozilla.org/mozilla-central/rev/d0065cf362cf
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox43: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
You need to log in before you can comment on or make changes to this bug.