Closed Bug 907124 Opened 7 years ago Closed 7 years ago

On certain pages, you can drag the page off the screen horizontally

Categories

(Core :: Layout, defect)

x86_64
Windows 8.1
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jimm, Unassigned)

References

Details

(Whiteboard: [block28])

STR:

1) open http://www.mozilla.org/en-US/contribute
2) once the page loads, drag the page horizontally

result: the page drags off the side of the screen

Letting the page sit for a bit so that it works through an animation cycle or two seems to fix the problem.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
Did a pull to confirm this. It's less likely to happen, but if you grab the right are at the right time, you can still reproduce.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Blocks: 915723
No longer blocks: metro-apzc
I was able to reproduce this loading the URL in question. Logging showed that when the page is first loaded, the scrollable rect in the FrameMetrics is (0, 0, 4899.00, 2433.85) and then at some later point changes to (0, 0, 1376.00, 2433.85). That is, the layer corresponding to the page is super wide, allowing horizontal scrolling. I'm not entirely sure why the layer is so wide. I can't reproduce that behaviour on my OS X desktop release build. The scrollable rect is set at [1] as the sum of the scroll range and the scroll port sizes, and in this case it is the scroll range that is too large. This seems solidly like a layout bug (or possibly expected behaviour, depending on what the page is doing).

[1] http://mxr.mozilla.org/mozilla-central/source/layout/base/nsDisplayList.cpp?rev=0ef00ffc6c12#665
Component: Pan and Zoom → Layout
Product: Firefox for Metro → Core
Whiteboard: [blocker]
Whiteboard: [blocker] → [block28]
Kats, I'm not seeing this anymore. Can you confirm?
I can't repro either, although I've been having a lot of problems with my build so I'm not confident in this. Close for now and reopen if it comes back?
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → WORKSFORME
No longer blocks: 915723
Blocks: metro-apzc
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.