Unquoted comma in name sends mail to two users

VERIFIED DUPLICATE of bug 89198

Status

MailNews Core
Composition
VERIFIED DUPLICATE of bug 89198
17 years ago
10 years ago

People

(Reporter: Peter Janes, Assigned: varada)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
If an address of the form

Last, First <user@domain.invalid>

is entered in an address line in a mail message, the message is actually sent to
two recipients, Last@domain.default (with no display name) and
user@domain.invalid (with the display name "First").  However, if the address is
entered

"Last, First" <user@domain.invalid>

the message is correctly sent to the single user specified.

While the behaviour may be technically correct (is it?), it's very annoying in
an Exchange LDAP environment where names are returned in the former form.  It's
also somewhat counterintuitive: the name is listed on a single line, so it's
expected that the message will go to a single user.

This behaviour has appeared recently, perhaps in the last week or two.  I've
entered such an address myself, so it's not restricted to addresses retrieved
from the LDAP server.
Linux -sea.tar.gz 2001071006 on fully-patched Red Hat 6.2.
compose -> ducarroz, varada
Assignee: sspitzer → varada
Component: Mail Window Front End → Composition
(Reporter)

Comment 2

17 years ago
I reported this originally; is it actually a dup of bug 89198?  That one relates
to the unquoted comma, but doesn't mention the extra e-mail being sent.

Comment 3

16 years ago
'Last' is correct email address, so what can we do here?
Only close as wontfix :-) It's impossible to work around
all buggy software in existense - we'll end up with tons 
of new bugs...
(Reporter)

Comment 4

16 years ago
This works now as it should (despite Denis' comment).  I'm guessing the dup I
mentioned previously is actually the case, so will mark it as such.

*** This bug has been marked as a duplicate of 89198 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
verified
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.