disable whatsnew for official branding

VERIFIED FIXED in Firefox 24

Status

()

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Gavin, Assigned: Gavin)

Tracking

unspecified
Firefox 26
Points:
---

Firefox Tracking Flags

(firefox24 verified, firefox25 verified, firefox26 verified)

Details

Attachments

(1 attachment)

Currently, the official branding package displays a whatsnew page:

https://www.mozilla.org/%LOCALE%/firefox/%VERSION%/whatsnew/?oldversion=%OLD_VERSION%

In practice, we disable that page for updates using the functionality from bug 538331 (see also bug 682805, attachment 569544 [details] [diff] [review]).

That leaves the page showing if users update manually, though. Since we've determine that we don't want to be showing this page on every update, we should disable the page in the product as well, so it's disabled consistently regardless of the update mechanism.

Comment 1

5 years ago
LGTM
Created attachment 793098 [details] [diff] [review]
patch
Assignee: nobody → gavin.sharp
Status: NEW → ASSIGNED
Attachment #793098 - Flags: review?(dolske)
This will mean we implement bug 892972 differently, but that's fine if this change makes it to Firefox 25.
Blocks: 892972
Attachment #793098 - Flags: review?(dolske) → review+

Comment 4

5 years ago
I like this, now we're just waiting on Asa.
Flags: needinfo?(asa)
See comment 1!
Flags: needinfo?(asa)
Comment on attachment 793098 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): N/A
User impact if declined: useless whatsnew pages appear for manual updates
Testing completed (on m-c, etc.): none
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #793098 - Flags: approval-mozilla-beta?
Attachment #793098 - Flags: approval-mozilla-aurora?

Comment 8

5 years ago
Comment on attachment 793098 [details] [diff] [review]
patch

so few letters in that comment that I missed it :)
Attachment #793098 - Flags: approval-mozilla-beta?
Attachment #793098 - Flags: approval-mozilla-beta+
Attachment #793098 - Flags: approval-mozilla-aurora?
Attachment #793098 - Flags: approval-mozilla-aurora+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/613a1db679dc
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Keywords: checkin-needed
Whiteboard: [c-n for beta/aurora]

Comment 10

5 years ago
When will the whatsnew start to be disabled on all downloads/silent updates?
https://hg.mozilla.org/releases/mozilla-aurora/rev/d3736955cf31
https://hg.mozilla.org/releases/mozilla-beta/rev/ba0b21a948d5
status-firefox24: --- → fixed
status-firefox25: --- → fixed
status-firefox26: --- → fixed
Keywords: checkin-needed
Whiteboard: [c-n for beta/aurora]

Updated

5 years ago
Keywords: verifyme
Verified as fixed on: Win 8 32bit, Mac 10.8.4 and Ubuntu 13.04 32bit.

Whatsnew page doesn't appear anymore when first opening Firefox 24 RC (as opposed to Firefox 23), in both of the next scenarios:

1) when making a simple installation of FF 24
2) when making a pave-over install of FF 24 over FF 23
status-firefox24: fixed → verified
QA Contact: manuela.muntean
(In reply to Chris More [:cmore] from comment #10)
> When will the whatsnew start to be disabled on all downloads/silent updates?

"silent" updates never got whatsnew, but the change in this bug (disable for non-updater triggered updates) will take effect in Firefox 24 (see status flags).
Verified as fixed on: Win 7 32bit, and Ubuntu 12.10 32bit.

Whatsnew page doesn't appear anymore when first opening Firefox 25 beta 1 (build ID: 20130917123208), in both of the next scenarios:

1) when making a simple installation of FF 25 beta 1
2) when making a pave-over install of FF 25 beta 1 over FF 24 beta 2

Updated

5 years ago
status-firefox25: fixed → verified
Mozilla/5.0 (X11; Linux i686; rv:26.0) Gecko/20100101 Firefox/26.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:26.0) Gecko/20100101 Firefox/26.0

Verified as fixed on latest Aurora 26.0a2 (buildID: 20131003004003).
Status: RESOLVED → VERIFIED
status-firefox26: fixed → verified
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.