bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

WebRTC misconfigures on Android somehow, builds cpu_info as though it were Linux rather than Android

RESOLVED FIXED in Firefox 24

Status

()

Core
WebRTC
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: philor, Assigned: glandium)

Tracking

Trunk
mozilla26
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox24 fixed, firefox25 fixed, firefox26 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Second time we've seen this: https://tbpl.mozilla.org/php/getParsedLog.php?id=26786385&tree=Mozilla-Inbound is an Android build trying to find get_nprocs, which it should only be doing for Linux && !Android, but it died with

../../../../../../../../media/webrtc/trunk/webrtc/system_wrappers/source/cpu_info.cc: In static member function 'static uint32_t webrtc::CpuInfo::DetectNumberOfCores()':
../../../../../../../../media/webrtc/trunk/webrtc/system_wrappers/source/cpu_info.cc:43:35: error: 'get_nprocs' was not declared in this scope

despite the previous build being perfectly happy. glandium has a theory, which is good since I only have a bafflement.
(Assignee)

Comment 1

5 years ago
Previous Android Armv6 build on the same slave:
https://tbpl.mozilla.org/php/getParsedLog.php?id=26770736&tree=Mozilla-Inbound

That previous build was a clobber. It thus ran configure.
The build corresponding to the log in comment 0 is an incremental build with webrtc changes in it. It didn't run configure, but ran gyp_chromium from the rule in the generated media/webrtc/trunk/common.mk. The problem is that gyp_chromium is not called with the -G os=android argument in that case.
(Assignee)

Comment 2

5 years ago
Created attachment 793213 [details] [diff] [review]
Handle generator_flags gracefully in gyp

This is the easy fix.
Attachment #793213 - Flags: review?(gps)
(Assignee)

Updated

5 years ago
Assignee: nobody → mh+mozilla

Comment 3

5 years ago
Comment on attachment 793213 [details] [diff] [review]
Handle generator_flags gracefully in gyp

Review of attachment 793213 [details] [diff] [review]:
-----------------------------------------------------------------

What could possibly go wrong?
Attachment #793213 - Flags: review?(gps) → review+

Comment 5

5 years ago
https://hg.mozilla.org/mozilla-central/rev/2d271df63cff
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
Comment on attachment 793213 [details] [diff] [review]
Handle generator_flags gracefully in gyp

[Approval Request Comment]
Bug caused by (feature/regressing bug #): N/A

User impact if declined: Possibility of mysterious clobber-needing failures in automation as we've seen

Testing completed (on m-c, etc.): On m-c

Risk to taking this patch (and alternatives if risky): close to nil, and any failures would be to incremental builds

String or IDL/UUID changes made by this patch: none
Attachment #793213 - Flags: approval-mozilla-beta?
Attachment #793213 - Flags: approval-mozilla-aurora?
Comment on attachment 793213 [details] [diff] [review]
Handle generator_flags gracefully in gyp

Approving, :glandium can you please make sure the aurora/beta builds are generated smoothly given the risk that is called out.
Attachment #793213 - Flags: approval-mozilla-beta?
Attachment #793213 - Flags: approval-mozilla-beta+
Attachment #793213 - Flags: approval-mozilla-aurora?
Attachment #793213 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/d6fa49bcf953
https://hg.mozilla.org/releases/mozilla-beta/rev/558ce0ef3f08
status-firefox24: --- → fixed
status-firefox25: --- → fixed
status-firefox26: --- → fixed
You need to log in before you can comment on or make changes to this bug.