[Buri][PLMN]Networt name in PLMN list is not same as idle show

RESOLVED WONTFIX

Status

P1
normal
RESOLVED WONTFIX
5 years ago
8 months ago

People

(Reporter: sync-1, Unassigned, Mentored)

Tracking

unspecified

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Whiteboard: [good first bug][mentor-lang=zh])

Attachments

(2 attachments)

306.46 KB, text/plain
Details
7.85 MB, application/octet-stream
Details
(Reporter)

Description

5 years ago
AU_LINUX_GECKO_ICS_STRAWBERRY.01.01.00.019.190
 Firefox os  v1.1
 Mozilla build ID:20130812041203
 
 DEFECT DESCRIPTION:
 Networt name in PLMN list is not same as idle show.
 
  REPRODUCING PROCEDURES:
 Case1:
 SIM with EF_SPN 00 
 When register on HPLMN, in idle only SPN is shown, but in PLMN search list, static name is shown;-->KO
 
 Case2:
 SIM with OPL/PNN
 When register on PLMN that in OPL list, in idle only PNN is shown, but in PLMN search list, static name is shown;-->KO
 
  EXPECTED BEHAVIOUR:
 Network name in search list should be same as idle
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 5/5
 
  For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

5 years ago
Clone from brother
(Reporter)

Comment 2

5 years ago
Created attachment 793248 [details]
radio log
(Reporter)

Comment 3

5 years ago
Clone from brother
(Reporter)

Comment 4

5 years ago
Created attachment 793249 [details]
QXDM log

Updated

5 years ago
blocking-b2g: --- → leo?

Comment 5

5 years ago
Hi, 
for test case3: short name is showed instead of longname in plmn list.

I find in newlistitem() in gaia/app/setting/carrier.js for 852035. Why? 
-name.textContent = network.longName;
+name.textContent = network.shortName || network.longName;

I need to change to :
name.textContent = network.longName || network.longName;

Will it be ok?

Updated

5 years ago
blocking-b2g: leo? → koi?

Updated

5 years ago
blocking-b2g: koi? → leo?
Evelyn, could this be a regression from bug 852038?

I'm also wondering if comment 5 meant to say:

name.textContent = network.longName || network.shortName; // not longName twice

?
Flags: needinfo?(ehung)
yangshjuan@tcl.com, please see my second question in comment 6.
Flags: needinfo?(yangshjuan)
Andrew,

Assigning this bug to you for further analysis, since you  are already looking into it.
Assignee: nobody → overholt

Comment 9

5 years ago
Hi, 
I mean, at first the code was:
name.textContent = network.longName;

later, for bug 852035, it is modified like following:
name.textContent = network.shortName || network.longName;

now, bug 907507 asks to show longName first. i need to change to:
name.textContent = network.longName || network.shortName;

Will this affect bug 852035?
Flags: needinfo?(yangshjuan)
Assignee: overholt → ehung
Can someone help confirm if this is the same behaviour in 1.0.1 .If its a regression from bug 852038, then it would be and I think it is ok to ship it in the same way for 1.1 as well given where we are.(needinfo  	
Evelyn Hung )

Comment 11

5 years ago
No, it's not a regression from bug 852038.
Flags: needinfo?(ehung)

Comment 12

5 years ago
(In reply to yangshjuan from comment #9)
> Hi, 
> I mean, at first the code was:
> name.textContent = network.longName;
> 
> later, for bug 852035, it is modified like following:
> name.textContent = network.shortName || network.longName;
> 
> now, bug 907507 asks to show longName first. i need to change to:
> name.textContent = network.longName || network.shortName;
> 
> Will this affect bug 852035?

I don't see any patch for bug 852035. From the comments on that bug, it seems a totally different problem that trying to do ADN editing.
I believe switching network.longName and network.shortName doesn't matter in this case. Would you like to provide a patch?
Flags: needinfo?(yangshjuan)
Evelyn

What is the user impact if the bug is not fixed. Sounds like a naming convention.
Flags: needinfo?(ehung)

Comment 14

5 years ago
I'm not sure about the user impact... From my point of view, yes, it's more like a convention.
Flags: needinfo?(ehung)
very minimal user impact and hence minus
blocking-b2g: leo? → -

Comment 16

5 years ago
clear ni flag, and label good first bug for someone who is looking for a easier start.
Flags: needinfo?(yangshjuan)
Whiteboard: [good first bug]
Whiteboard: [good first bug] → [good first bug][mentor=ehung][mentor-lang=zh]

Comment 17

5 years ago
I'd like to be a mentor of this bug.
Assignee: ehung → nobody

Updated

4 years ago
Mentor: ehung
Whiteboard: [good first bug][mentor=ehung][mentor-lang=zh] → [good first bug][mentor-lang=zh]

Comment 18

4 years ago
Hi,
I'm new to open source.
I'm looking for my first bug.
Can u assign this bug to me?

Comment 19

4 years ago
Hi, Anindya-Pandey; welcome aboard. We'd love to assign this to you, and as soon as you've got a patch ready to go we can do that. 

Building FirefoxOS can be a challenge, but our documentation is pretty good. You can get started here:

https://developer.mozilla.org/en-US/Firefox_OS/Building_and_installing_Firefox_OS

and as soon as you're able to build from source successfully, you'll be on your way.

Evelyn, listed in Mentor's field above, can answer questions about what this change looks like. Thanks for your effort, and good luck!

Comment 20

4 years ago
Hi, Mike Hoye. I've already built and installed the Gaia user interface. What else do I need?

Comment 21

4 years ago
Evelyn can answer that question, I think - I've called her attention to this with the "need more info" box you see below, and selecting "mentor". 

Evelyn, what do you think?

Updated

3 years ago
Blocks: 1258652

Comment 22

8 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.