Closed Bug 907518 Opened 9 years ago Closed 4 years ago

[Buri][Browser]Tencent webpage display abnormal

Categories

(Web Compatibility :: Mobile, defect, P5)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: sync-1, Assigned: karlcow)

References

()

Details

(Whiteboard: [sprintready][country-cn][contactready])

Attachments

(2 files)

Mozilla build ID:20130806071254
 
 Created an attachment (id=495510)
 Tencent webpage display abnormal
 
 DEFECT DESCRIPTION:
  Tencent webpage display abnormal
 
  REPRODUCING PROCEDURES:
  1.launch browser->input url"http://info.3g.qq.com"->find the webpage is confusion and has overlay-->KO
 
  EXPECTED BEHAVIOUR:
  KO:Tencent webpage display normally
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
  Free Test
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
  Medium
 
  REPRODUCING RATE:
  5/5
  For FT PR, Please list reference mobile's behavior:
Clone from brother
Clone from brother
Attached file jrdlog_511331.rar
Whiteboard: sprintready
A Pivotal Tracker story has been created for this Bug: http://www.pivotaltracker.com/story/show/55927230
This happens in Firefox for Android. It does not happen in Stock, Chrome, Opera or Dolphin.
Karen Rudnitski deleted the linked story in Pivotal Tracker
Component: Gaia::Browser → Mobile
Product: Boot2Gecko → Tech Evangelism
Whiteboard: sprintready → [sprintready][country-cn]
Whiteboard: [sprintready][country-cn] → [sprintready][country-zh]
Whiteboard: [sprintready][country-zh] → [sprintready][country-cn]
This URL sends WAP content to the FirefoxOS UA. I reported 922289 on that - *this* report is only about the layout issues.
See Also: → 922289
The site uses a pretty confusing mix of server-side sniffing, session data and redirects to serve different content to different browsers. If I emulate Chrome's user-agent with a clean session, I get the correct-looking page. We should recommend that both Firefox OS and Firefox on Android get that same treatment on the backend.
Whiteboard: [sprintready][country-cn] → [sprintready][country-cn][contactready]
Oddly this worked fine at first sight today - as I was about to mark it as WFM, the problem re-occurred though, but not until I went to 3g.qq.com and was *redirected* to info.3g.qq.com. Don't know if that matters - but going to the latter URL directly with no history seemed to work just fine..
See Also: 922289866577
When requesting with Firefox OS UA, info.3g.qq.com or 3g.qq.com, we do not get redirected to the same content.

* info.3g.qq.com 302 text/html         200 text/vnd.wap.wml
* 3g.qq.com      200 text/vnd.wap.wml  200 text/vnd.wap.wml

But then the wml story is a bit more complex. The first card is 

> <wml>
> <card id="qq" ontimer="http://info.3g.qq.com/g/s?aid=index&amp;s_it=1&amp;g_from=3gindex&amp;&amp;g_f=1283" title="手机腾讯网">
> <timer value="1"/>
> <p align="center">
> <br/>
> <br/>
> 欢迎进入<br/>
> 手机腾讯网...<br/>
> <a href="http://info.3g.qq.com/g/s?aid=index&amp;s_it=3&amp;g_from=3gindex&amp;&amp;g_f=1283">3g.qq.com</a><br/>
> </p>
> </card></wml>
> 

So it is being redirected to 
http://info.3g.qq.com/g/s?aid=index&s_it=1&g_from=3gindex&&g_f=1283

but both redirects to WML content. 
I'm not sure if it's what is happening on the device itself.


# info.3g.qq.com
GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: info.3g.qq.com
User-Agent: Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

HTTP/1.1 302 Found
Cache-Control: no-cache
Content-Length: 98
Content-Type: text/html; charset=utf-8
Date: Wed, 11 Dec 2013 16:36:30 GMT
Location: http://info.3g.qq.com/g/s?aid=index&from=wap3g&s_it=1&sid=00
Pragma: no-cache
Server: HTTP Load Balancer/1.0

Then let's follow

GET /g/s?aid=index&from=wap3g&s_it=1&sid=00 HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: info.3g.qq.com
User-Agent: Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

HTTP/1.1 200 OK
Cache-Control: no-cache
Content-Type: text/vnd.wap.wml; charset=utf-8
Date: Wed, 11 Dec 2013 16:43:19 GMT
Pragma: no-cache
Server: HTTP Load Balancer/1.0
Set-Cookie: g_ut=1; domain=.qq.com; path=/; expires=Sun, 09-Feb-2014 16:43:19 GMT
Set-Cookie: info_gqq=CwzjkwrA; domain=.3g.qq.com; path=/; expires=Thu, 12-Dec-2013 16:43:19 GMT
Set-Cookie: JSESSIONID=aaaZjW4GPetYxhhSOIIlu; path=/
Transfer-Encoding: chunked






# 3g.qq.com

GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: 3g.qq.com
User-Agent: Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

HTTP/1.1 200 OK
Cache-Control: no-cache
Content-Encoding: gzip
Content-Length: 350
Content-Type: text/vnd.wap.wml; charset=UTF-8
Date: Wed, 11 Dec 2013 16:36:52 GMT
Pragma: no-cache
Server: HTTP Load Balancer/2.0
Set-Cookie: JSESSIONID=aaa5RVUszmSPq-4kkHIlu; path=/


after WAP redirection

GET /g/s?aid=index&s_it=1&g_from=3gindex&&g_f=1283 HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: info.3g.qq.com
User-Agent: Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

HTTP/1.1 200 OK
Cache-Control: no-cache
Content-Type: text/vnd.wap.wml; charset=utf-8
Date: Wed, 11 Dec 2013 16:42:26 GMT
Pragma: no-cache
Server: HTTP Load Balancer/1.0
Set-Cookie: g_ut=1; domain=.qq.com; path=/; expires=Sun, 09-Feb-2014 16:42:26 GMT
Set-Cookie: info_gqq=CwyyQ5cM; domain=.3g.qq.com; path=/; expires=Thu, 12-Dec-2013 16:42:26 GMT
Set-Cookie: JSESSIONID=aaaLeP3wbb5oV_dOBIIlu; path=/
Transfer-Encoding: chunked
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
This seems to be resolved. I don't see any display issues with Firefox Android 26 on a Samsung.
Can someone else test?
Assignee: nobody → kdubost
Status: NEW → ASSIGNED
I think it works..
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
main navigation menu is now laid out vertically instead of horizontally.

.main-nav-list{display: -webkit-box}

also needs display:flex

CSS from http://3glogo.gtimg.com/wap30/info/info5/css/indexSVG-min2014042488002.css
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Status: REOPENED → NEW
Priority: P2 → P5
Closing as we are not working on Firefox OS anymore.
Status: NEW → RESOLVED
Closed: 8 years ago4 years ago
Resolution: --- → WONTFIX
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.