If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

button in file upload control never appears to take focus and doesn't take focus on mousedown

VERIFIED DUPLICATE of bug 52815

Status

()

Core
Layout: Form Controls
--
minor
VERIFIED DUPLICATE of bug 52815
16 years ago
16 years ago

People

(Reporter: Jesse Ruderman, Assigned: Brian Ryner (not reading))

Tracking

({access, testcase})

Trunk
mozilla1.0
access, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
The button in a file upload control never appears to take focus, and when you
mousedown on it, the textbox is focused instead.

Steps to reproduce:

1. Go to http://bugzilla.mozilla.org/createattachment.cgi?id=52815

2. Mousedown on the "browse" button.
 Result: browse button doesn't appear to take focus, and the textbox now has focus.
 Expected: browse button should take focus and appear to take focus.

3. Press tab once from the textbox.
 Result: textbox appears to have focus, but the button has focus.
 Expected: the button should have and appear to have focus.

4. Press tab a second time.
 Result: focus is in la-la land but focus *still* appears to be in the textbox.
 Expected: go to the next focusable object (bug 52815).

May be related to bug 52500, whacked rendering of css styles on file upload control.

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.5

Comment 1

16 years ago
2. Mousedown on the "browse" button.

This works for me now

3. Press tab once from the textbox.

This is still an issue

4. Press tab a second time.

This works now

Giving to bryner for tabbing issue. 
Assignee: saari → bryner
Status: ASSIGNED → NEW
Target Milestone: mozilla0.9.5 → mozilla0.9.6
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Keywords: access
OS: Windows NT → All
Hardware: PC → All
(Assignee)

Updated

16 years ago
Target Milestone: mozilla0.9.6 → mozilla0.9.7
(Assignee)

Comment 2

16 years ago
Not gonna make it for 0.9.7.
Target Milestone: mozilla0.9.7 → mozilla1.0

Comment 3

16 years ago
*** Bug 112624 has been marked as a duplicate of this bug. ***

Comment 4

16 years ago
Created attachment 61617 [details]
reduced testcase

Updated

16 years ago
Keywords: testcase
(Assignee)

Comment 5

16 years ago

*** This bug has been marked as a duplicate of 52815 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 6

16 years ago
Verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.