classList adding multiple class values

RESOLVED DUPLICATE of bug 814014

Status

Developer Documentation
API: DOM
RESOLVED DUPLICATE of bug 814014
5 years ago
5 years ago

People

(Reporter: sasklacz, Assigned: David Bruant)

Tracking

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130814063812

Steps to reproduce:

In the first example on https://developer.mozilla.org/en-US/docs/Web/API/element.classList page there is shown a code sample, where classList.add gets multiple values. 


Actual results:

In reality 'add' appends only the first value, and the rest is discarded.


Expected results:

Either it's a bug in classList implementation in Gecko, or bug in MDN documentation.
(Assignee)

Comment 1

5 years ago
(In reply to Jakub Siemiatkowski (:sasklacz) from comment #0)
> Either it's a bug in classList implementation in Gecko, or bug in MDN
> documentation.
Bug in Gecko. I added a note in the doc.

Thanks for the report!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 814014
You need to log in before you can comment on or make changes to this bug.