ImageContainer.h:11:10: fatal error: GeckoProfilerFunc.h' file not found (non-SPS)

RESOLVED FIXED in mozilla26

Status

()

Core
Graphics: Layers
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Jan Beich, Assigned: Jan Beich)

Tracking

Trunk
mozilla26
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Assignee)

Description

5 years ago
On platforms without SPS profiler the build is broken due to
GeckoProfilerFunc.h not being exported.

gfx/gl/GLContext.cpp:14:
In file included from dist/include/gfxUtils.h:12:
dist/include/ImageContainer.h:11:10: fatal error:
GeckoProfilerFunc.h' file not found
#include "GeckoProfilerFunc.h"          // for TimeStamp
         ^
(Assignee)

Comment 1

5 years ago
Created attachment 793587 [details] [diff] [review]
remove bogus include

TimeStamp and TimeDuration are in mozilla/TimeStamp.h while *_sampler_* functions defined in GeckoProfilerFunc.h are unused in those files.
Attachment #793587 - Flags: review?(ncameron)
(Assignee)

Comment 2

5 years ago
Created attachment 793593 [details] [diff] [review]
use stable header
Attachment #793593 - Flags: review?(ncameron)

Updated

5 years ago
Attachment #793587 - Flags: review?(ncameron) → review+

Updated

5 years ago
Attachment #793593 - Flags: review?(ncameron) → review+

Updated

5 years ago
Duplicate of this bug: 907731
I'm puzzled because i dont see that failure, and we dont have the SPS profiler on OpenBSD..
Thanks nick!
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
And now i know why i didnt see that failure... since 903816/Include-what-you-use landed, the two patches dont apply anymore, and are not needed ? Removing checkin-needed until someone sorts this out....
Keywords: checkin-needed

Comment 7

5 years ago
(In reply to Landry Breuil (:gaston) from comment #6)
> And now i know why i didnt see that failure... since
> 903816/Include-what-you-use landed, the two patches dont apply anymore, and
> are not needed ? Removing checkin-needed until someone sorts this out....

I think the problem is caused by 903816 and these patches fix it. They should apply now.
Ok, disregard my remark then. I tried applying/pushing those two commits this morning, and failed. Maybe a local thing with my m-i clone. And i finally saw the same failure on some of my builders....
https://hg.mozilla.org/mozilla-central/rev/2ed38ca05fd2
https://hg.mozilla.org/mozilla-central/rev/806a989ec3ad
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
You need to log in before you can comment on or make changes to this bug.