Long tapping on a bookmark thumbnail and then long-tapping on an empty thumbnail spot displays in its context menu 'Open in New tab' and 'Open in Private Tab'

VERIFIED FIXED in Firefox 26

Status

()

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: aaronmt, Assigned: Margaret)

Tracking

26 Branch
Firefox 26
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Currently one can long-tap on an empty thumbnail position and the context menu will display 'Open in New Tab' and 'Open in Private Tab' on an empty thumbnail spot.

Steps to Reproduce

On a new profile

i) Long tap 'Firefox: Customize with add-ons'
ii) Long tap on the open 'Add a Bookmark' spot below it

Expected: 'Edit' as the sole item
Actual: 'Open in New Tab' & 'Open in Private Tab'
(Assignee)

Comment 2

5 years ago
This shouldn't be too hard to fix.
Assignee: nobody → margaret.leibovic
(Assignee)

Comment 3

5 years ago
Created attachment 793720 [details] [diff] [review]
patch

Well, this turned out to be tricky! The problem is that we aren't updating the position of the normal cursor in the TopSitesCursorWrapper if we move beyond valid position values for it. This means that if you have 2 sites (default case on first run), move to position 1 (long tapping the AMO thumbnail), then move to position 3 (long tapping the thumbnail under that), we don't update the normal cursor, so it thinks it's still at position 1, when it really should be at position 2 (meaning that it's positioned after the last row).

This patch fixes this problem by making sure we always move the normal cursor, even if we're trying to move to a position beyond its bounds.
Attachment #793720 - Flags: review?(wjohnston)
Comment on attachment 793720 [details] [diff] [review]
patch

Review of attachment 793720 [details] [diff] [review]:
-----------------------------------------------------------------

Tricky.
Attachment #793720 - Flags: review?(wjohnston) → review+
https://hg.mozilla.org/mozilla-central/rev/1a8030bb148e
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26
(Reporter)

Updated

5 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.