about:addons content disappears when scrolling page with mouse wheel or trackpad

RESOLVED FIXED in mozilla26

Status

()

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: cpeterson, Unassigned)

Tracking

({regression})

unspecified
mozilla26
x86
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(firefox25 unaffected, firefox26 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
STR:
1. Load about:addons
2. Scroll the page with a mouse wheel or trackpad

RESULT:
The list of addons disappeared, but the rest of the page is still visible.

This bug also affects the "Edit Page" textarea of wiki.mozilla.org but Wikipedia:

https://wiki.mozilla.org/index.php?title=Firefox&action=edit

https://en.wikipedia.org/w/index.php?title=Firefox&action=edit


This bug look like another regression from OSX texture bug 900133.

This is a regression in Nightly build 2013-08-21. I bisected the TBPL builds from mozilla-inbound from the prior day and the regression range is includes bug 900133:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=0f68b32be429&tochange=252dbb41d609
Created attachment 794448 [details] [diff] [review]
Align strides to at least 4

We get a cairo error on smaller strides and cairo refuses to draw our mask.
Attachment #794448 - Flags: review?(nical.bugzilla)
Created attachment 794450 [details] [diff] [review]
Use pixman for mask layers

This works around some weird Quartz bugs with A8 surfaces. Previously we just manually cleared these surfaces instead (see the #ifdef XP_MACOSX in ISurfaceAllocator.cpp), but I think this makes more sense.
Attachment #794450 - Flags: review?(nical.bugzilla)
Comment on attachment 794448 [details] [diff] [review]
Align strides to at least 4

Review of attachment 794448 [details] [diff] [review]:
-----------------------------------------------------------------

::: gfx/layers/ImageDataSerializer.cpp
@@ +73,5 @@
>                                            gfx::SurfaceFormat aFormat)
>  {
>    // Note that at the moment we pack the image data with the minimum possible
>    // stride, we may decide to change that if we want aligned stride.
> +  uint32_t bufsize = aSize.height * ComputeStride(aFormat, aSize.width);

please remove the comment above now that we have an aligned stride.
Attachment #794448 - Flags: review?(nical.bugzilla) → review+

Updated

5 years ago
Attachment #794450 - Flags: review?(nical.bugzilla) → review+
> please remove the comment above now that we have an aligned stride.

Actually never mind, it is Saturday for Matt so I fixed the comment and will land as soon as inbound reopens
Just relanding the first part, since the latter caused a bunch of fuzz failures.

https://hg.mozilla.org/integration/mozilla-inbound/rev/8358b10c9b4f
https://hg.mozilla.org/mozilla-central/rev/8358b10c9b4f
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
You need to log in before you can comment on or make changes to this bug.