Closed Bug 908068 Opened 7 years ago Closed 7 years ago

[MP] Defect - After providing wrong username/password/recovery key Sync considers the device connected

Categories

(Firefox for Metro Graveyard :: Sync, defect, P2)

All
Windows 8.1
defect

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 26

People

(Reporter: flod, Assigned: emtwo)

References

Details

(Whiteboard: [preview] feature=defect c=sync_features u=metro_firefox_user p=1)

Attachments

(1 file)

1) Open Sync on an unpaired device and select Set Up Sync.

2) You'll see the pairing code, select "I'm not near my computer…"

3) Provide wrong credentials (e.g. "testmetro" everywhere) and try to connect, you'll receive a wrong username or password warning

4) Go back to Sync, it will say you're using an account "testmetro", last sync empty and you can add a device.
Summary: After providing wrong username/password/recovery key Sync considers the device connected → Defect - After providing wrong username/password/recovery key Sync considers the device connected
Whiteboard: [preview-triage] feature=defect c=tbd u=tbd p=0
OS: Windows 8 → Windows 8 Metro
Summary: Defect - After providing wrong username/password/recovery key Sync considers the device connected → [MP] Defect - After providing wrong username/password/recovery key Sync considers the device connected
Whiteboard: [preview-triage] feature=defect c=tbd u=tbd p=0 → [preview] feature=defect c=tbd u=tbd p=0
Assignee: nobody → msamuel
Blocks: metrov1it15
No longer blocks: metrov1backlog
Status: NEW → ASSIGNED
Priority: -- → P2
QA Contact: jbecerra
Whiteboard: [preview] feature=defect c=tbd u=tbd p=0 → [preview] feature=defect c=tbd u=tbd p=1
Attachment #802665 - Flags: review?(ally)
Comment on attachment 802665 [details] [diff] [review]
v1: Specifically check for successful login before displaying the 'connected' screen

Review of attachment 802665 [details] [diff] [review]:
-----------------------------------------------------------------

works as expected, mochitests pass, and looks good. 

Noticed an issue with the persisting error strings after disconnect, but that seems unrelated. I'll file a bug.
Attachment #802665 - Flags: review?(ally) → review+
I don't see the bad behavior after re-running your patch on m-c, so I think your fix will obviate it. I'll document it here then.

STR
- Go to sync flyout
- Go to "I'm not near my computer" aka manual setup
- Enter incorrect credentials for username/password/encryption key
- Go back to main sync flyout & push disconnect
- Wait for disconnect to finish & reset the main sync flyout
- Revisit manual set up screen
Expected
- No red error string
Actual
- Red error string below the edit boxes about incorrect credentials.
https://hg.mozilla.org/integration/fx-team/rev/21b501262dda
Whiteboard: [preview] feature=defect c=tbd u=tbd p=1 → [fixed-in-fx-team][preview] feature=defect c=tbd u=tbd p=1
https://hg.mozilla.org/mozilla-central/rev/21b501262dda
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team][preview] feature=defect c=tbd u=tbd p=1 → [preview] feature=defect c=tbd u=tbd p=1
Target Milestone: --- → Firefox 26
Whiteboard: [preview] feature=defect c=tbd u=tbd p=1 → [preview] feature=defect c=sync_features u=metro_firefox_user p=1
Blocks: 831615
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.