Closed Bug 908133 Opened 8 years ago Closed 8 years ago

Throw a SyntaxError when creating a function which name is a reserved keyword

Categories

(Core :: JavaScript Engine, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 907958

People

(Reporter: bruant.d, Unassigned)

Details

Context:
https://mail.mozilla.org/pipermail/es-discuss/2013-August/032804.html
https://mail.mozilla.org/pipermail/es-discuss/2013-August/032811.html

Currently, SpiderMonkey doesn't think that "function function(){}" is a big deal.

Nothing pressing really, just filing to remember.
Might be a good candidate for a mentored bug for someone who'd want to start playing with the JS parser.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 907958
You need to log in before you can comment on or make changes to this bug.