on slideshare.net, some slidesets do not display

RESOLVED WORKSFORME

Status

Tech Evangelism
Mobile
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: karlcow, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mobile-compat-form], URL)

(Reporter)

Description

5 years ago
Site: http://slideshare.net/mobile/nuuneoi/mobile-market-past-present-now-and-then
on slideshare.net, some slidesets do not display

:: Steps To Reproduce

1. With Firefox 0S, ZTE device.
2. Go to http://slideshare.net/mobile/nuuneoi/mobile-market-past-present-now-and-then


:: Expected Result

Going through the slides.

:: Actual Result

Not working: Once I select a slideset. The slideset page is showing up, but then I have the spinning wheel for ever without any slides displayed.    Note: Firefox doesn't have flash. 

:: Additional Information

Software Version: 1.1
Device Information: ZTE roamer2
Reporter's User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:23.0) Gecko/20100101 Firefox/23.0
(Reporter)

Updated

5 years ago
See Also: → bug 827666
(Reporter)

Comment 1

5 years ago
Saptarshi, if you have any clues, tell us.
(Reporter)

Updated

5 years ago
Flags: needinfo?(saptarshi)
I've seen this issue on desktop when spoofing as Firefox OS, but could not at the time reproduce on the phone. It's like it's waiting for an onload event on an IMG element that fails to fire..?
[10:45:58.153] ReferenceError: SSBandInteraction is not defined @ http://public.slidesharecdn.com/javascripts/ssplayer/combined_mobile_scroll_player.js?c55c1ebae7:222

SSBandInteraction is used here:

this.config.touch?(b.touchInteraction=new SSTouchInteraction({container:b.slidedisplayer.container,playerType:this.config.player_type,hostedIn:this.config.hosted_in}),b.navigators.push(b.touchInteraction)):"document"!==
this.config.player_type&&("video"!==this.config.player_type&&"infographic"!==this.config.player_type)&&(b.bandInteraction=new SSBandInteraction({container:b.slidedisplayer.container,width:b.width,linksDisabled:this.config.disable_links}),b.navigators.push(b.bandInteraction))

so maybe this.config.touch is false and should be true? Well, this sort of explains why it fails on a spoofing desktop but should work on mobile:

(code defining Modernizr.touch, I assume):
e.touch="ontouchstart"in a||9===c.touch.offsetTop

this.config.touch=a&&(Modernizr.touch||"Windows Phone"==a)&&!cookie("nomobile");
(I have not stepped through code or anything - the above is not analysis, just guesswork)

I can not reproduce on the phone - only on desktop. Karl, still seeing this?

(On the other hand, sometimes when scrolling down a long presentation the screen goes black - is that an OOM? That would be our problem anyway, not something for Slideshare to fix IMO.)
Flags: needinfo?(saptarshi)
I'm unable to reproduce after going through about 10 slidedecks. Please reopen if you can still see this problem Karl. <3
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.