All users were logged out of Bugzilla on October 13th, 2018

Failure in testPrivateDownloadPanel.js due to changes in nsIDownloadManager

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: AndreeaMatei, Assigned: teodruta)

Tracking

unspecified

Firefox Tracking Flags

(firefox35 disabled, firefox36 disabled, firefox37 disabled, firefox38 fixed, firefox-esr31 disabled)

Details

(Whiteboard: [mozmill-test-failure][regression][mozmill-test-skipped][Blocked by bug 908649], URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Started failing today, most likely after the changes from bug 847863. Happens with Nightly on all platforms and locales.

Currently investigating.
(Reporter)

Updated

5 years ago
status-firefox26: --- → affected
Priority: -- → P1
(Reporter)

Comment 1

5 years ago
Cosmin, could you please create a skip patch for this so I can land it? Thanks.

Comment 2

5 years ago
Created attachment 794044 [details] [diff] [review]
skip.patch

Skip patch attached.

Fix might take a while, the plan is to remove nsiDownloadManager completely, don't know yet how much code we will need to update.
Assignee: nobody → andrei.eftimie
Status: NEW → ASSIGNED
Attachment #794044 - Flags: review?(andreea.matei)
(Reporter)

Comment 3

5 years ago
Comment on attachment 794044 [details] [diff] [review]
skip.patch

Review of attachment 794044 [details] [diff] [review]:
-----------------------------------------------------------------

Skipped:
http://hg.mozilla.org/qa/mozmill-tests/rev/20a1239372ff (default)
Attachment #794044 - Flags: review?(andreea.matei) → review+
(Reporter)

Updated

5 years ago
status-firefox26: affected → disabled
Whiteboard: [mozmill-test-failure][regression] → [mozmill-test-failure][regression][mozmill-test-skipped]

Updated

5 years ago
Depends on: 908649
Do we have any update here? This P1 is skipped for a whole month now without any further action taking place.

Comment 5

5 years ago
We need to completely recreate the downloads lib as the new architecture is very different from the old one. I've tried just updating code to use the new API's but I failed halfway through as architecturally they don't match at all. The old lib doesn't make any more sense with the new async promise-based API's.

I've spun off bug 908649 for this.
(In reply to Andrei Eftimie from comment #5)
> I've spun off bug 908649 for this.

I know, but also there no work happened in the last whole month. Not even a comment about the current state or any feedback requests because of possible blockers.

Updated

4 years ago
Assignee: andrei.eftimie → nobody
Status: ASSIGNED → NEW

Updated

4 years ago
Assignee: nobody → daniel.gherasim
Status: NEW → ASSIGNED
Whiteboard: [mozmill-test-failure][regression][mozmill-test-skipped] → [mozmill-test-failure][regression][mozmill-test-skipped][Blocked by bug 908649]
(Assignee)

Updated

4 years ago
status-firefox26: disabled → ---
status-firefox35: --- → disabled
status-firefox36: --- → disabled
status-firefox37: --- → disabled
status-firefox38: --- → disabled
status-firefox-esr31: --- → disabled
(Reporter)

Comment 7

4 years ago
Backed out skip patch:
https://hg.mozilla.org/qa/mozmill-tests/rev/8dd6c8c1b7ef (default)

This will ride the trains along with the downloads refactor.
(Reporter)

Updated

4 years ago
Assignee: danisielm → teodor.druta
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-firefox38: disabled → fixed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.