If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

product/component searching should sort hits on product/component name before hits on descriptions

RESOLVED FIXED

Status

()

bugzilla.mozilla.org
Extensions: ProdCompSearch
RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: Aleksej, Assigned: glob)

Tracking

Production

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 794236 [details]
screenshot of results for "layout", "dom" and "buil"

Some queries at https://bugzilla.mozilla.org/describecomponents.cgi give poor results — maybe returning all components from a product that has matching components.

"Layout" and "DOM" give "Core :: Layout" or "Core :: DOM", respectively, and after that apparently just every component of Core, instead of "Core :: Layout: *" / "Core :: DOM: *".  "layou" gives all components of "Core :: DOM".

"buil" gives many Boot2Gecko components which have no "buil" in their names or descriptions, but there is "Boot2Gecko :: Builds" (which is not shown first among anything).  "build" seems to return only relevant results.
(Assignee)

Comment 1

4 years ago
tricky.

> maybe returning all components from a product that has matching components.

this isn't what's happening..

> "Layout" and "DOM" give "Core :: Layout" or "Core :: DOM", respectively, and
> after that apparently just every component of Core, instead of "Core ::
> Layout: *" / "Core :: DOM: *".  "layou" gives all components of "Core ::
> DOM".
>
> "buil" gives many Boot2Gecko components which have no "buil" in their names
> or descriptions, but there is "Boot2Gecko :: Builds" (which is not shown
> first among anything).  "build" seems to return only relevant results.

component searching searches product and component descriptions for the words as a substring.  when sorting the results, if a product or component matches exactly the query, it will be sorted first, with all other results sorted alphabetically.

for both of your examples, the *product's* description is matching.

eg. Boot2Gecko's description is "FirefoxOS, or Boot2Gecko (B2G) is Mozilla's operating system built on web standards", which matches "buil".


sounds like we need to sort product/name matches before description matches.
Severity: major → normal
OS: Linux → All
Hardware: x86_64 → All
Summary: describecomponents.cgi is broken for some searches like "layout" or "dom" or "buil": shows one match and, e.g., everything from a product which has a matching component → product/component searching sort results by relevance, giving description hits lower priority than name hits
(Assignee)

Updated

4 years ago
Duplicate of this bug: 897205
(Assignee)

Updated

4 years ago
Summary: product/component searching sort results by relevance, giving description hits lower priority than name hits → product/component searching should sort hits on product/component name before hits on descriptions
(Assignee)

Updated

2 years ago
Assignee: nobody → glob
(Assignee)

Comment 3

2 years ago
To ssh://gitolite3@git.mozilla.org/webtools/bmo/bugzilla.git
   014dc85..d1419f8  master -> master
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.