Persona login doesn't work in WebApp installed in Firefox for Android

RESOLVED DUPLICATE of bug 826325

Status

()

Firefox for Android
Web Apps
RESOLVED DUPLICATE of bug 826325
4 years ago
4 years ago

People

(Reporter: stomlinson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: A4A)

(Reporter)

Description

4 years ago
Copied from https://github.com/mozilla/browserid/issues/3807

I put a simple Persona login into one of my sites. The login works on Firefox and Firefox OS - no matter if opened in a browser tab or as a installed WebApp. It works also on Firefox for Android (23 stable up to 26 nightly), but *not as a WebApp, that is installed in Firefox for Android*.

*Expected result:*
The navigator.id.request() call should open a login screen.

*Actual result:*
The navigator.id.request() call does nothing.

That's the website: http://www.birdgames.de/
WebApp Manifest: http://www.birdgames.de/birdgames.webapp

*Steps to reproduce:*
* mobile view: Click "Login" in the main menu. The main menu can be opened at the top left corner.
* desktop and tablet view: Click "Login" in the footer menu (scroll to the bottom of the page).

I haven't found and issue that tracks that problem. Also I've tried to use remote debugging to figure out the problem, but remote debugging doesn't work with WebApps on FF for Android.
(Reporter)

Updated

4 years ago
Whiteboard: A4A
This is bug 826325. Its fallen to the bottom of my queue.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 826325
You need to log in before you can comment on or make changes to this bug.