Closed Bug 908747 Opened 8 years ago Closed 8 years ago

Talos regression tp4m_nochrome (Main RSS) 3% on Android 4.0.4 and 2% on Android 2.2 on Aug 21 2013

Categories

(Firefox for Android Graveyard :: General, defect)

x86
Android
defect
Not set
normal

Tracking

(fennec26+)

RESOLVED FIXED
Firefox 26
Tracking Status
fennec 26+ ---

People

(Reporter: gbrown, Assigned: sriram)

References

Details

(Keywords: perf, regression)

From dev-tree-management Digest, Vol 56, Issue 112:

Date: Thu, 22 Aug 2013 00:01:50 -0000
Subject: <Regression> Mozilla-Inbound - Tp4 Mobile NoChrome (Main RSS)
        -        Android 4.0.4 - 3.31%

Regression: Mozilla-Inbound - Tp4 Mobile NoChrome (Main RSS) - Android 4.0.4 - 3.31% increase
---------------------------------------------------------------------------------------------
    Previous: avg 171140500.000 stddev 330009.504 of 12 runs up to revision b7fbfd4de77c
    New     : avg 176813333.333 stddev 259731.796 of 12 runs since revision ab6bc4d9e4c0
    Change  : +5672833.333 (3.31% / z=17.190)
    Graph   : http://mzl.la/1at3iD9

Changeset range: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=b7fbfd4de77c&tochange=ab6bc4d9e4c0


Subject: <Regression> Mozilla-Inbound - Tp4 Mobile NoChrome (Main RSS)
        -        Android 2.2 (Native) - 2.58%

Regression: Mozilla-Inbound - Tp4 Mobile NoChrome (Main RSS) - Android 2.2 (Native) - 2.58% increase
----------------------------------------------------------------------------------------------------
    Previous: avg 132585416.667 stddev 488107.376 of 12 runs up to revision b7fbfd4de77c
    New     : avg 136004333.333 stddev 667865.437 of 12 runs since revision ab6bc4d9e4c0
    Change  : +3418916.667 (2.58% / z=7.004)
    Graph   : http://mzl.la/14XQTil

Changeset range: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=b7fbfd4de77c&tochange=ab6bc4d9e4c0


Appears to be caused by the fig merge -- not surprising and nothing to get excited about!
Assignee: nobody → lucasr.at.mozilla
tracking-fennec: ? → 26+
It seems that the fix bug 904172 got us back to normal RSS-wise. See:

http://graphs.mozilla.org/graph.html#tests=[[136,63,29]]&sel=none&displayrange=30&datatype=running

Given that this is a fig-specific fix, I'd say there's a fair chance this patch actually fixed our main source of regression somehow. To be very honest here though, it's not entirely clear why the patch fixed the regression. It pretty much caches the measured dimensions of about:home's top bookmarks grid. Maybe the extra layout rounds on the grid was creating extra memory usage (something related to the thumbnails?).
Geoff, thoughts? It seems like the regression has been fixed by the patch mentioned above. Do you feel like we should do further investigation before closing?
Flags: needinfo?(gbrown)
I don't have a strong opinion. 

Certainly there was a significant improvement on Sept 9/10...but did that address the cause of the regression, or was it an independent improvement? And is it worth investigating? It's up to you.
Flags: needinfo?(gbrown)
Given that the code in question was added as part of the initial code landing, I think the improvement is not independent.

Fixed by bug 904172
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Assignee: lucasr.at.mozilla → sriram
Depends on: 904172
Target Milestone: --- → Firefox 26
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.