OdinMonkey: Differential Testing: Different error message involving --ion-eager

RESOLVED FIXED in mozilla26

Status

()

defect
--
major
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: gkw, Assigned: luke)

Tracking

(Blocks 3 bugs, {testcase})

Trunk
mozilla26
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

try {
    (function() {
        e(function() {
            {
                "use asm"
            }
        })
    })()
} catch (e) {}


shows the following on a 32-bit debug deterministic threadsafe js shell on m-c rev fb2318875cd4 with --ion-eager:

1comparejit.js:5:16 warning: "use asm" is only meaningful in the Directive Prologue of a function body:
1comparejit.js:5:16 warning:                 "use asm"
1comparejit.js:5:16 warning: ................^
1comparejit.js:5:16 warning: "use asm" is only meaningful in the Directive Prologue of a function body:
1comparejit.js:5:16 warning:                 "use asm"
1comparejit.js:5:16 warning: ................^

but shows the following without any CLI arguments:

1comparejit.js:5:16 warning: "use asm" is only meaningful in the Directive Prologue of a function body:
1comparejit.js:5:16 warning:                 "use asm"
1comparejit.js:5:16 warning: ................^

(Pass in the testcase as a CLI argument to reproduce)

There is an extra copy of the warning. Is this intended?
Flags: needinfo?(luke)
Posted patch fix-warningSplinter Review
Oh, haha, we report the warning once during the syntax-only parse and again during the full parse.  Probably doesn't matter, but trivial to fix.
Assignee: general → luke
Status: NEW → ASSIGNED
Attachment #794820 - Flags: review?(bbouvier)
Flags: needinfo?(luke)
Comment on attachment 794820 [details] [diff] [review]
fix-warning

Review of attachment 794820 [details] [diff] [review]:
-----------------------------------------------------------------

Nice catch!
Attachment #794820 - Flags: review?(bbouvier) → review+
https://hg.mozilla.org/mozilla-central/rev/143b76709fab
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
You need to log in before you can comment on or make changes to this bug.