Closed Bug 908908 Opened 7 years ago Closed 7 years ago

Suppress the false positive rooting hazard on OnFinalize

Categories

(Core :: JavaScript Engine, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 931912

People

(Reporter: terrence, Assigned: terrence)

References

Details

Attachments

(1 file)

This indirect call is only called during sweeping and has a single, trivial implementation.
Attachment #794912 - Flags: review?(sphink)
Comment on attachment 794912 [details] [diff] [review]
suppress_onfinalize-v0.diff

Review of attachment 794912 [details] [diff] [review]:
-----------------------------------------------------------------

As discussed over IRC, annotating this function as a non-gcFunction will not prevent its body from being scanned for hazards. We'll need to either whitelist the particular nsCOMPtr::nsCOMPtr involved, or reimplement AutoAssertNoGC and teach the analysis to pay attention to it.
Attachment #794912 - Flags: review?(sphink)
And we have AutoAssertNoGC again, but not before I forgot about this bug.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 931912
You need to log in before you can comment on or make changes to this bug.