Closed Bug 908958 Opened 8 years ago Closed 8 years ago

Scrolling misbehaviour with long iframe in B2G browser

Categories

(Core :: Graphics: Layers, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 904533

People

(Reporter: botond, Assigned: botond)

References

Details

When vertically scrolling the iframe on this page: http://people.mozilla.org/~kgupta/tmp/iframe.html in the B2G browser, I see the following misbehaviours:

 1) When the 1500-1600 pixel mark is reached, rendering stops below
    that point. The exact point at which rendering stops changes
    as you scroll, but it's within that range. This may be a
    displayport issue.

 2) When further scrolling is attempted after the above point is
    reached, the iframe jumps to around the 1100-1200 pixel position.

This is with today's m-c on an Unagi device.
Blocks: 907179
Assignee: nobody → botond
The problem was that FrameMetrics::mCompositionBounds was computed incorrectly for subframes. Since bug 904533 also involved changes to how mCompositionBounds is computed, I combined my fix for this with the changes in that bug and uploaded the combined patch to that bug.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 904533
You need to log in before you can comment on or make changes to this bug.