For a pinned tab, when clicking a URL in the Bookmarks Toolbar, the new URL opens in a new tab instead of in the existing pinned tab.

REOPENED
Unassigned

Status

()

REOPENED
6 years ago
5 months ago

People

(Reporter: t8av, Unassigned)

Tracking

23 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130814063812

Steps to reproduce:

I selected a pinned tab, and then clicked a URL in the Bookmarks Toolbar.


Actual results:

The new URL opened in a new tab.


Expected results:

The new URL should be opened in the existing pinned tab.

It is very annoying that you try to load a URL into a specific tab, while Firefox decided for you to open it in a new tab.

 Firefox should follow user's request!!!. As simple as that.

( Bug https://bugzilla.mozilla.org/show_bug.cgi?id=598587 seems to request for the opposite, and this should be reversed ).
Hello, I think this could be a design choice: in fact why would you open a new URL inside a pinned tab, if the purpose of it should be to always have that certain website you pinned opened in the browser? A pinned tab is different from a regular tab.

However the developers will tell you better if it's a request that they will take into account or not.

Thanks for your report!
Status: UNCONFIRMED → NEW
Component: Untriaged → Tabbed Browser
Ever confirmed: true
This is working as intended, see bug 579872.
Blocks: 579872
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

6 years ago
I am very disappointed by your response.

The current behavior of the pinned tab is against any human intuition and should be changed.
(Reporter)

Comment 4

6 years ago
I strongly disagree to close this bug without a more serious discussion. In my point of view, this is one of the most annoying bugs.

When the user clicks a link within a tab, this is exactly what should happen.

Currently, the user clicks a link (sometimes from the bookmarks toolbar), which is opened in a new tab instead of the current tab, unless they are from the same domain.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(In reply to t8av from comment #4)
> I strongly disagree to close this bug without a more serious discussion.

You can have that on the firefox-dev@mozilla.org mailing list.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → INVALID
(In reply to t8av from comment #4)
> When the user clicks a link within a tab, this is exactly what should happen.

Yes, within A TAB, not a pinned tab. Pinned tabs have different functionality and have their own session. In other words they are separated from normal tabs.

Which leads us to conclusion that this bug report isn't about wrong pinned tab's behavior, this is about your complete lack of understatement what pinned tabs are for.
(Reporter)

Comment 7

6 years ago
(In reply to Peter Henkel [:Terepin] from comment #6)
> Which leads us to conclusion that this bug report isn't about wrong pinned
> tab's behavior, this is about your complete lack of understatement what
> pinned tabs are for.

Since you don't try to understand my point of view, and you insist on the definition of "pinned tabs" (where this definition came from? is it one of natures law?) then it is pointless to continue this discussion.

I apologize for my lack of understatement. I am not a highly sophisticated developer. I am just an unsatisfied user.
(Reporter)

Comment 8

4 years ago
One more point for consideration:

In Google Chrome, pinned tabs behave exactly as I requested.

Do they also have "complete lack of understatement what pinned tabs are for" (see comment 6).
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
That doesn't change the fact that pinned tabs are ment for concrete pages, not for shrinking tabs. What purpose would pinned tab has other than being smaller? None. If you want smaller tabs, use CSS. Case closed. Again.
(Reporter)

Comment 10

4 years ago
Reasons for using pinned tabs:

1. Smaller tabs.

2. Fixed location.

Remarks:
1. I don't see how is CSS related.

2. A quick "Case closed" is a good idea to avoid long discussions, and significantly reduce the number of bugs in bugzilla. You can apply your logic to all the other bugs in the system.

3. I have used Firefox for many years, and I do like it, but since I started using mostly Chrome, I found a browser that simply does what I want, without the need for me to fill-in a lot of bug reports (as I did for Firefox).
That fixed location won't do you much good when its content keeps changing all the time. My first sentence still apply.
(Reporter)

Comment 12

4 years ago
(In reply to Peter Henkel [:Terepin] from comment #11)
> That fixed location won't do you much good when its content keeps changing
> all the time. My first sentence still apply.

The content of the pinned tab does not "keep changing". It depends on what the user is doing.

In my opinion, the basic rule of how to setup a software tool (including Firefox), is to reflect the will of the user.

If the user wants to load the pinned tab with a different content - this is the way it should be.

Maybe, a small number of users might want a new window to be opened, so for them you can set a configuration parameter - "open a new window when pinned tab URL changes" (actually it is a domain change, not any URL change).

Comment 13

5 months ago
Seeing this reported behavior in my firefox instal. 
Also tried in New Profile. Same behavior.  
Expected: clicking on bookmarked URLs from inside pinned tab to open the page in same pinned tab.
Observed: clicking on bookmarked URLs from inside pinned tab opens the page in new unpinned tab instead. 
Reaction : annoying to the user. 

Firefox : 
Version 	63.0b4 , 
Build ID 	20180906162647, 
OS: Ubuntu 16.04, Linux 4.4.0-134-generic.  

Compared in Chrome Version 68.0.3440.106 , in same desktop.  
Clicking on bookmarked URLs from inside pinned tab opens the page inside the same pinned tab.
You need to log in before you can comment on or make changes to this bug.