Animated gif playback not optimal in ux nightly

RESOLVED DUPLICATE of bug 924366

Status

()

RESOLVED DUPLICATE of bug 924366
6 years ago
5 years ago

People

(Reporter: alexander, Unassigned)

Tracking

26 Branch
x86
macOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20130825040204

Steps to reproduce:

Load any reasonably large animated gif that the browser can't load fully right away


Actual results:

Playback started instantly and proceeded to play back until it ran out of data. Then playback started again at the beginning resulting in loops that kept growing longer the more data the browser received


Expected results:

Playback should start immediately and then stop when the browser runs out of data and not jump to the beginning and start playing again

Comment 1

6 years ago
Provide or attach such a GIF, please.
Flags: needinfo?(alexander)
(Reporter)

Comment 2

6 years ago
this for example jumps all over the place during initial load/playback through an admittedly pretty slow internet connection:

http://img838.imageshack.us/img838/4599/fortuna2.gif
Flags: needinfo?(alexander)

Updated

6 years ago
Component: Untriaged → ImageLib
Product: Firefox → Core
Duplicate of this bug: 909258
(Reporter)

Comment 4

6 years ago
here is another one i found that shows very erratic playback behavior:

http://farm8.staticflickr.com/7346/9587864202_c4d29e319d_o.gif
Works fine for me on the latest UX Nightly build (compared by playing the gifs from Comments 2 and 4 on Chrome 30.0.1599.69)
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:27.0) Gecko/20100101 Firefox/27.0
Build ID: 20131004040205

Alexander, are you still experiencing this issue? Could you please verify whether the issue is still reproducible if using Firefox with a new profile?
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

Updated

5 years ago
Flags: needinfo?(alexander)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(alexander)
Resolution: --- → DUPLICATE
Duplicate of bug: 924366
You need to log in before you can comment on or make changes to this bug.