Closed Bug 909380 Opened 8 years ago Closed 8 years ago

Autophone - s1s2 - Regression in "time to throbber stop" on Aug 24 2013

Categories

(Firefox for Android Graveyard :: General, defect)

x86
Android
defect
Not set
normal

Tracking

(fennec26+)

RESOLVED FIXED
Firefox 26
Tracking Status
fennec 26+ ---

People

(Reporter: gbrown, Assigned: froydnj)

References

(Blocks 1 open bug)

Details

(Whiteboard: perf, regression)

http://phonedash.mozilla.org/#/org.mozilla.fennec/throbberstop/local-blank/2013-08-19/2013-08-26/notcached/noerrorbars/standarderror shows a regression in "Time to throbber stop" for "Local blank page" on Aug 24, for (almost?) all devices.

As one example, consider 44_a7_cf_ea_f9_73_lg-revolution:

Fri Aug 23 2013 (ce881259e2d0): 6572±33
Sat Aug 24 2013 (17143a9a0d83): 7424±52
Assignee: nobody → lucasr.at.mozilla
tracking-fennec: ? → 26+
For reference, we merged fig to m-c on Aug 21 so this was caused by the merge itself at least. Looking at this graph here:

  http://phonedash.mozilla.org/#/org.mozilla.fennec/throbberstop/local-blank/2013-08-19/2013-09-12/notcached/noerrorbars/standarderror

The inbound -> m-c merge that caused the regression is this one:

  https://hg.mozilla.org/mozilla-central/rev/17143a9a0d83

By looking at the commit, the most likely offender is bug 906088 which got backed out on Aug 27 it seems. Here's the commit:

  https://hg.mozilla.org/mozilla-central/rev/c0d1baa50a64

This backout brought the numbers back to where they were. Then, still on Aug 27, it seems there's a slight regression probably caused by this merge here:

  https://hg.mozilla.org/mozilla-central/rev/416075f77249

This merge has a lot of stuff, hard to tell what patch caused it.

All in all, none of the suspect commits seem to be related to fig, which is good news I guess.
For the Aug 24 regression (this bug), I think we can say "fixed by backing out bug 906088"

Is there a bug filed for the Aug 28th throbberstop regression?
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
(In reply to Mark Finkle (:mfinkle) from comment #2)
> For the Aug 24 regression (this bug), I think we can say "fixed by backing
> out bug 906088"
> 
> Is there a bug filed for the Aug 28th throbberstop regression?

Not sure, filed and nominated bug 916099 just in case.
Assignee: lucasr.at.mozilla → nfroyd
Blocks: 906088
Target Milestone: --- → Firefox 26
Summary: Regression in "time to throbber stop" on Aug 24 2013 → Autophone - s1s2 - Regression in "time to throbber stop" on Aug 24 2013
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.