Closed Bug 909382 (SQLite3.8.0.2) Opened 6 years ago Closed 6 years ago

Upgrade to SQLite 3.8.0.2

Categories

(Toolkit :: Storage, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla27

People

(Reporter: ionnv, Assigned: RyanVM)

References

()

Details

Attachments

(1 file, 2 obsolete files)

http://www.sqlite.org/releaselog/3_8_0.html

http://www.sqlite.org/news.html

"SQLite version 3.8.0 might easily have been called "3.7.18" instead. However, this release features the cutover of the next generation query planner or NGQP, and there is a small chance of breaking legacy programs that rely on undefined behavior in previous SQLite releases, and so the minor version number was incremented for that reason. But the risks are low and there is a query planner checklist is available to application developers to aid in avoiding problems.

SQLite version 3.8.0 is actually one of the most heavily tested SQLite releases ever. Thousands and thousands of beta copies have be downloaded, and presumably tested, and there have been no problem reports.

In addition to the next generation query planner, the 3.8.0 release adds support for partial indices, as well as several other new features. See the change log for further detail."
https://tbpl.mozilla.org/?tree=Try&rev=91cbd25ad6ac

Build on top of m-c revision 14b1e8c2957e for performance comparisons.
Assignee: nobody → ryanvm
Status: UNCONFIRMED → ASSIGNED
Depends on: SQLite3.7.17
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86 → All
Try run isn't fully complete yet, but it's green enough that I think we're OK moving forward with a review.
Attachment #795763 - Flags: review?(mak77)
I think we are going to wait the begin of a release cycle to take this, considered the new query planner, we want a full cycle of baking to detect eventual perf regressions and have the time to work on them.
SQLite Release 3.8.0.1 On 2013-08-29 (3.8.0.1):
http://www.sqlite.org/releaselog/3_8_0_1.html

* Fix an off-by-one error that caused quoted empty string at the end of a CRNL-terminated line of CSV input to be misread by the command-line shell.
* Fix a query planner bug involving a LEFT JOIN with a BETWEEN or LIKE/GLOB constraint and then another INNER JOIN to the right that involves an OR constraint.
* Fix a query planner bug that could result in a segfault when querying tables with a UNIQUE or PRIMARY KEY constraint with more than four columns.
lulz
Summary: (SQLite3.8.0) Upgrade to SQLite 3.8.0 → (SQLite3.8.0.1) Upgrade to SQLite 3.8.0.1
Looks like the WinXP xpcshell failure is real. Doesn't happen on the parent m-c changeset.
https://tbpl.mozilla.org/php/getParsedLog.php?id=27223434&tree=Try
may be a timing issue, related to the new planner. is it reproducible locally?
I don't have XP handy to look, sorry.
It is interesting that the 3.8.0.0 Try run was green.
SQLite Release 3.8.0.2 On 2013-09-03 (3.8.0.2):
http://www.sqlite.org/changes.html

* Fix a bug in the optimization that attempts to omit unused LEFT JOINs.

Ryan - does this fixed bug related to the WinXP xpcshell failure?
Worth a shot!

https://tbpl.mozilla.org/?tree=Try&rev=a82c8cd8f465
Summary: (SQLite3.8.0.1) Upgrade to SQLite 3.8.0.1 → (SQLite3.8.0.2) Upgrade to SQLite 3.8.0.2
Though with the rate of bug fixes this release is getting, we may be up to version 3.8.1 before we take this :)
Attachment #797816 - Attachment is obsolete: true
Well, it's green on XP now. So maybe.
I don't think it's related cause the fix in 3.8.0.2 was a segfault. It's likely just intermittent.
Blocks: 879133
Comment on attachment 799406 [details] [diff] [review]
Upgrade to SQLite 3.8.0.2 - Mozilla changes

Ready to give this a shot? Last try run was green, but I can push it again if you like. I've been running with in my own builds without issue since it was released.
Attachment #799406 - Flags: review?(mak77)
Mak, ping? :)
Flags: needinfo?(mak77)
Comment on attachment 799406 [details] [diff] [review]
Upgrade to SQLite 3.8.0.2 - Mozilla changes

Review of attachment 799406 [details] [diff] [review]:
-----------------------------------------------------------------

yeah, the changelog sounds good, even if I wonder what's the difference between pragma query_only and read-only mode :)

it's likely we may need to update to 3.8.1 soon, though we should take this now to have more testing in Nightly of the new query planner.
Attachment #799406 - Flags: review?(mak77) → review+
Flags: needinfo?(mak77)
https://hg.mozilla.org/mozilla-central/rev/b8d8404a4721
https://hg.mozilla.org/mozilla-central/rev/65c4f1221204
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
Blocks: SQLite3.8.1
Alias: SQLite3.8.0.2
Summary: (SQLite3.8.0.2) Upgrade to SQLite 3.8.0.2 → Upgrade to SQLite 3.8.0.2
You need to log in before you can comment on or make changes to this bug.