[B2G][Buri] Unable to flash to Buri 08/26 master

RESOLVED FIXED

Status

Firefox OS
GonkIntegration
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Darren, Assigned: nhirata)

Tracking

({regression, smoketest})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
When trying to flash the phone the flashing process is interrupted by the phone running out of space.

Repro Results:
1. Plug in Buri Device with base image: 20130823
2. Flash using the manual flash method( putting the b2g and gaia folder inside with a full flash script)
3. Run the ./fullflash_gecko_ril_gaia.sh

Actual Results:
The flashing process stops with a message saying "No Space left on device".

Expected Results:
The phone will be flashed with the master build.

Notes:
Looks like between 08/23 and 08/26 the webapps folder grew by 12MB(not sure if that is the cause)

Log from flashing terminal
https://gist.github.com/anonymous/7f8d87335e088afc5afd
What happens if you flash a base image and then try to run the full flash script with today's build again?
Blocks: 884399
Keywords: regression, regressionwindow-wanted, smoketest
That may be due to the new keyboard dictionaries (see https://groups.google.com/forum/#!topic/mozilla.dev.b2g/Br0SHL4R4KA)
I was actually able to flash the buri device, but I cannot get beyond the home screen and the apps are missing from the dock.
If we're out of space, that is probably the result of the autocorrect dictionaries I added for bug 908286.  I posted to dev-b2g on Friday about the increase in size, but I was really hoping that it wouldn't cause this kind of problem.

What do we do?  Our partners need those dictionaries in 1.1, but the dictionaries make the build too big to fit on some phones.

If we need to back out 908286, we can do that, I suppose.
(In reply to David Flanagan [:djf] from comment #4)
> If we're out of space, that is probably the result of the autocorrect
> dictionaries I added for bug 908286.  I posted to dev-b2g on Friday about
> the increase in size, but I was really hoping that it wouldn't cause this
> kind of problem.
> 
> What do we do?  Our partners need those dictionaries in 1.1, but the
> dictionaries make the build too big to fit on some phones.
> 
> If we need to back out 908286, we can do that, I suppose.

Okay. Let's confirm the regression range to ensure it points to that bug. If it does, I'd say let's defensively backout that patch to get the build to be flashable again and I'll ask rel eng to respin.

Does that sound okay?
Sure, that sounds fine.  But then I'll have to figure out some other way to get the autocorrect dictionaries on the phone in a more configurable way.

I'm assuming that someone else is confirming the regression range and doing the backout?  Let me know if you need me to take any action here.
(Reporter)

Comment 7

5 years ago
So looks like with a fresh Buri Base image, the master build is flashed properly.

Looks like there might be some residual information being retained with the fullflash_gecko_ril_gaia.sh(Just a thought)
David, can you back out while we figure out what's going on an unblock QA?
(In reply to Fabrice Desré [:fabrice] from comment #8)
> David, can you back out while we figure out what's going on an unblock QA?

Looks like we have found the root cause per comment 7 - we might be orphaning files every time the full flash script runs. That implies that the patch djf landed probably isn't the root cause - it's a bug in flashing script.

We probably don't need to backout now. Thanks for the timely response though.
Keywords: regressionwindow-wanted
I got different results than Darren does in Comment 7. I started with a clean 8-15 base image and then flashed today's hamachi build using the full flash script. My device cannot get past the first screen and dock icons are missing - same issue that happened in Comment 3.
(In reply to Marcia Knous [:marcia] from comment #10)
> I got different results than Darren does in Comment 7. I started with a
> clean 8-15 base image and then flashed today's hamachi build using the full
> flash script. My device cannot get past the first screen and dock icons are
> missing - same issue that happened in Comment 3.

Missing homescreen icons are unrelated. I backed out the commit from Bug 893800.
Assignee: nobody → nhirata.bugzilla
to note : I had flashed using OTA and it had failed as well.
Found out that when flashing with gaia: 0035590eefc1ac6cfc05cfa868ed646f9f545e0c and gecko 7dc9265ed90037fbd273a05d322637931191d87a the web apps were there and I was able to use buri just fine.

The latest build : 2013-08-26-16-32-55 which is : 23343e6ea3cc59c3ab0ac9188aaa657bd11da4fd
has a bad pull request : 70ab35f0141f6e64fa00e173ebd099697e80c0f2 
which was backed out of after the build had completed : 42948607a36dd132a55a573e9e5fb462c1d4f202

Requesting a newer build with a newer pull.  Trying to determine the latest rev that's good before asking for another build currently.  I may have bricked my device due to the flash program crashing in the middle of flashing.  Not sure ETA.
Pretty sure my buri is bricked; having said that, what I'm checking for is the gaia version to be correct.  Tested the gaia on unagi.

I used gaia version : 2e8d9135f87357db2af59ef4917cf8b0918f5df2

Can we respin a build based off of gaia revision: 2e8d9135f87357db2af59ef4917cf8b0918f5df2
please?
Closing this out: 8/27/2013 build seems to flash.  It seemed to be the builds themselves due to the pulls.
No modification to the script was done as far as I know.

Flashing with the US-8-23 build + today's gecko/gaia should do the trick.  Confirmed with amaxwell.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.