links in mail msg should open in last-active browser window, not oldest window

RESOLVED WORKSFORME

Status

MailNews Core
Backend
RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: bobj, Unassigned)

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2008-08-25)

(Reporter)

Description

17 years ago
In Netscape 4.x, if I click on a link in a mail message it opens in
the topmost browser window.  When using 4.x, I would often alt-tab (in
Windows) to bring to the top the browser window that I want to use
for opening a link in a mail message, then al-tab back to the message
and click the link.  That does not work in Mozilla.  I'm not sure how
mail determines which browser window to use.

Comment 1

17 years ago
*** Bug 90993 has been marked as a duplicate of this bug. ***
Well, when I clicked on a link in mail it seemed nothing happened. The problem
was the link showed in a tab that happened (surprisingly) to already show a web
page and happened to be on another desktop. I do not know how the tab was
selected but I usually have web pages shown for some reason and do not want them
to change to something I was sent in email. And it may be hard to find the
correct window if you have ten of them already opened.

I think links from email should open in completely new window or the same window
as the email (could an email window change into browser window? At least in the
window I get from search which shows just the one message and some toolbars I
wouls expect it to do so unless new window is explicitly requsted).
seems related to bug 35578 - may be solved be fixing that
*** Bug 111447 has been marked as a duplicate of this bug. ***

Comment 5

16 years ago
I agree. This is really annoying. Unless you open in a new window, mail links
always open in the first browser window that was opened, not in the topmost
(active) window. This usually trashes my java api browser window :-(.

Comment 6

16 years ago
*** Bug 149948 has been marked as a duplicate of this bug. ***

Comment 7

16 years ago
*** Bug 62797 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Summary: links in mail msg should open in topmost browser window → links in mail msg should open in last-active browser window, not oldest window

Comment 8

15 years ago
I notice that if I click links from Eudora, they DO open in the last selected
Mozilla window, but when I click from inside Mozilla, they open in the original
Mozilla window's currently selected tab (i.e. in the window that loaded up when
I open Mozilla).

I guess that suggests a work-around of faking the open-window message from 'Mail
& Newsgroups' to appear to be external to Mozilla, but I don't know how hard
that would be.

I've taken to middle-clicking (open-in-new-tab) links from newsgroups to prevent
this behaviour. Surely it cannot be too hard to add a 'When I click a
newsgroup/mail message, send it to...' option, with at least an 'existing' and a
'new' window selection?

Comment 9

15 years ago
I have found a workaround for this. I am using tabbed browsing, and have my
middle button set to open a link in a new tab. When I middle-click a link in the
message window, it opens a new tab in the last-active browser window. Of course,
the bug still needs fixed, but this might help until it does.
Product: MailNews → Core

Comment 10

10 years ago
do yo ustill see this at any time?
Assignee: mscott → nobody
QA Contact: esther → backend
Whiteboard: closeme 2008-08-25

Comment 11

10 years ago
I do not see this now
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
RESO WFM per last comment.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.