Change - Cancelling active download once everything is dismissed

RESOLVED DUPLICATE of bug 904702

Status

defect
RESOLVED DUPLICATE of bug 904702
6 years ago
5 years ago

People

(Reporter: kjozwiak, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

6 years ago
Currently when you dismiss all the app bars that are associated with the download, there's no way of stopping an active download. I can see the progress using the "blue ring" but what if I wanted to cancel it? Seems like there's nothing you can do.

Steps to reproduce the issue:

1) Open Firefox Metro
2) Go to ubuntu.com and select "Desktop" at the top and then "Get Ubuntu now"
3) Pick any version from the list and start the download (You will receive an app bar stating that you will like to either "Run", "Save", "Cancel" or "X")
4) Select the "Save" button and then dismiss the "progress app bar" by pressing "X"

You will now see the progress on the Navigation App Bar (blue circle) but lets say I want to cancel now?

Current Behavior:

- When you dismiss all of the download app bars, there's no way of cancelling the download once its in the "blue circle" state

Expected Behavior:

- I think it would be a good idea if the user could cancel somehow rather then waiting till it completes

Used the following build:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-08-27-03-02-01-mozilla-central/
I've wondered about this as well. Should the downloads button bring up some sort or downloads ui?

Updated

6 years ago
Whiteboard: feature=defect c=Downloads_app_bar u=metro_firefox_user p=0 → [preview-triage] feature=defect c=Downloads_app_bar u=metro_firefox_user p=0
Yeah I think the bug here is that clicking on the down arrow button (it gets the blue progress ring when a download is in progress) should bring up the downloads notification which has the cancel action on it. Currently, clicking on it does nothing.
Actually scratch that. Notifications are designed to go away for good once dismissed. ISTM that clicking the appbar download button should get me that info one way or another. And as the notification bar was where I last saw info about my download, maybe its reasonable to expect it to come back even after I clicked the 'X' to make it go away?
Flags: needinfo?(ywang)
Bug 904702 will make it possible to bring back the download bar and then use it to cancel the current download(s).
Depends on: 904702
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Flags: needinfo?(ywang)
Resolution: --- → DUPLICATE
Duplicate of bug: 904702
No longer blocks: metrov1backlog, 886942
Whiteboard: [preview-triage] feature=defect c=Downloads_app_bar u=metro_firefox_user p=0
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.