"BSD Type: L8" alert msg when clicking download link

VERIFIED FIXED in mozilla0.9.3

Status

()

VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: jj.enser, Assigned: dougt)

Tracking

Trunk
mozilla0.9.3
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.2) Gecko/20010713
BuildID:    2001071305

An alert stating "BSD Type: L8" pops up when attempting to download a file from
the url above and no download takes place.
IE 5.1 downloads that same file (.dmg.gz type) as expected when the same link is
clicked.

Reproducible: Always
Steps to Reproduce:
1.Go to url: http://www.apple.com/downloads/macosx/productivity_tools/jcalendar.html
2.click on the link to download jCalendar.
->  an alert pops up ("BSD Type: L8") and no download takes place.

Expected Results:  file gets downloaded as with IE 5.1
confirming with win2k build 20010715..

->FTP
see bug 84472 (marking depency)
Assignee: pchen → dougt
Component: Browser-General → Networking: FTP
Depends on: 84472
QA Contact: doronr → tever
OS: MacOS X → All
Hardware: Macintosh → All
(Assignee)

Updated

18 years ago
Target Milestone: --- → mozilla0.9.3
(Assignee)

Comment 2

18 years ago
the actual url with the problem is above.  The site is returning a non standard
system.  I will add a check for this in our handling, but this really is a
workaround to a poorly set up ftp server.
(Assignee)

Comment 3

18 years ago
I checked in fixes for this bug this afternoon.  QA, please verify.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

18 years ago
Thanks Doug, I will also give it a try.
btw, I saw a similar type of error when trying to ftp to a MacOSX box (from
OS9). Exact msg was : "UNKNOWN type: L8". Expected ftp listing shows up fine in 4.x
Is this the same bug?
(Assignee)

Comment 5

18 years ago
Hey JJ,
The problem that you describe is a different problem.  The ftp logic, as it is
today, requires that the ftp server return a valid known SYST response.  The
current valid and known responses that we handle are "windows" and "unix"
(including bsd - this bug).

The server that you are referring to, sends UNKNOWN back.  Because of this we
have no idea (as it is currently design) to know what LIST format it will send
back.    
It is a bug - the 'ftp to index-html' converter should not require any knowledge
of what the LIST format is prior to parsing.  If it didn't, we could support a
wider range of server LIST formats.
(Reporter)

Comment 6

18 years ago
Are you saying that every time we'll encounter a new SYST type running an ftp
server, we'll be hosed?
That would be bad :-)

How come 4.x displays the content of my OSX machine without any problem?

Is there any plan to fix the underlying bug you're talking about (accepting a
wider range of LIST formats) ?
(Assignee)

Comment 7

18 years ago
I am saying that we only support SYST responses of UNIX or WINDOWS.

This worked in 4.x cause its LIST parsing worked totally different.

I am not sure if there is a bug assigned to me regarding this problem (there may
be).  This probably will be a hot item for the osx users.

Comment 8

17 years ago
verified - not seeing BSD alert message
WinNT4 2001082803
Mac os9 2001082908
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.