Closed Bug 910215 Opened 11 years ago Closed 11 years ago

Preview video on apprtc is mirrored

Categories

(Core :: WebRTC: Audio/Video, defect)

ARM
Android
defect
Not set
normal

Tracking

()

RESOLVED INVALID
Tracking Status
firefox24 - affected
firefox25 --- affected
firefox26 --- affected

People

(Reporter: u421692, Unassigned)

References

(Depends on 1 open bug)

Details

Environment:
Device: LG Nexus 4 (Android 4.2.2)
Build: Firefox 26.0a1 (2013-08-27)

Steps to reproduce:
1. Open http://www.apprtc.webrtc.org
2. Select to share "Back facing" camera
3. Observe the video preview as you rotate the phone on "Y" axis

Expected result:
The video is displayed correctly.

Actual result:
The video is mirrored, you can easy see the issue when pointing the camera at some text(the text is displayed flipped/backwards; please see attached screenshot)

Note: This is reproducing on all devices I've tested, so it's not a specific device issue.
I can't reproduce on http://mozilla.github.io/webrtc-landing/gum_test.html
tracking-fennec: --- → ?
Reproduces on apprtc.webrtc.org but not the gum test, so it's not a gUM issue. 

I think the rotation is being done by apprtc.
This "reproduces" on desktop with Firefox and Chrome as well. apprtc is mirroring the image so the preview looks exactly as if you would watch a mirror. Whether that's really desirable is up for discussion, but not our problem and not our bug.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → INVALID
Summary: Preview video is mirrored when using back camera → Preview video on apprtc is mirrored
Fwiw, I can reproduce this on codeshare.io as well
We don't expose the property that allows the site to determine whether the front or back camera is active, and this mirroring is fairly standard for video-conferencing sites:
http://dev.w3.org/2011/webrtc/editor/getusermedia.html#video-facing-mode-enum
http://dev.w3.org/2011/webrtc/editor/getusermedia.html#idl-def-MediaSourceStates

But that's pretty much a separate bug with different testcases.
Depends on: 910249
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.